Closed Bug 822526 Opened 7 years ago Closed 7 years ago

Turn Image into an interface

Categories

(Core :: ImageLib, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: seth, Assigned: seth)

References

Details

Attachments

(1 file, 1 obsolete file)

We want to be able to wrap images and transform them or add additional behavior. This will be used in the implementation of media fragments in bug 790640. (Almost there!) To do this, Image must be an interface rather than an abstract class, as we need to be able to wrap all Image methods, and the wrappers won't need the state that the current Image abstract class contains.
Here we go.
I pulled this out of a larger patch in case it was controversial. Running a try job on this piece alone to make sure I didn't miss anything: https://tbpl.mozilla.org/?tree=Try&rev=44835893ded2
Rebased. Going ahead and requesting review.
Attachment #694074 - Flags: review?(joe)
Attachment #693211 - Attachment is obsolete: true
The previous try job had a failure that I'm fairly certain was caused by an earlier buggy version of bug 821023. That bug's now fixed. Here's a new try job running against the rebased version: https://tbpl.mozilla.org/?tree=Try&rev=0e8436efeeab
Comment on attachment 694074 [details] [diff] [review]
Turn mozilla::image::Image into an interface.

Review of attachment 694074 [details] [diff] [review]:
-----------------------------------------------------------------

Not controversial at all!
Attachment #694074 - Flags: review?(joe) → review+
@Joe: Great! Thanks for the review.

The try job looks good (a few unrelated intermittent oranges, but nothing caused by this patch). Requesting checkin.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4425abacc947
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.