Closed Bug 822675 Opened 7 years ago Closed 7 years ago

pref to disable add-ons when entering per-window private browsing

Categories

(Firefox :: Private Browsing, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: curtisk, Unassigned)

References

Details

(Whiteboard: [parity-chrome])

We should have a pref that allows the disabling of some or all extensions and add-ons when entering private browsing mode. We are currently the opposite in that we allow everything when entering PB (chrome is explicit allow). We should decide to either keep the current behavior and allow the disabling or disable all and allow selective enableing
Note that it's not possible to disable non-bootstrapped addons without restarting the browser.
Summary: pref to disable add-ons when entering pre-window PB (parity chrome) → pref to disable add-ons when entering per-window private browsing
Whiteboard: [parity-chrome]
Bug 463027 is being used as a tracker for blockers for release of the feature, and I don't believe this qualifies.
No longer blocks: PBnGen
(In reply to Josh Matthews [:jdm] from comment #2)
> Bug 463027 is being used as a tracker for blockers for release of the
> feature, and I don't believe this qualifies.

Given that the old PB model caused all add-ons to be disabled (or am I wrong), I think this should block release. This could cause a serious privacy breach when in PB that we don't intend.
You are incorrect in that assertion.
Unless we have a good way of disabling add-ons on a given window, this is WONTFIX.  Adding support for that seems impossible in practice because at the very least we should not assume that we get to change all of the add-ons.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
we can start the browser without any addons directly with the -saf-mode flag can we not use that code? I think we need a pref that users can control if it's all or nothing for now that is better than not having an option at all.
(In reply to Curtis Koenig [:curtisk] from comment #6)
> we can start the browser without any addons directly with the -saf-mode flag
> can we not use that code?

That code involves restarting the browser. We can't restart the browser to start a new private browsing window. Short of other major architectural changes (like e10s), it's not really possible to do this currently.
Is it even possible to disable Bootstrapped Addons for certain windows? I guess not. 

How about adding a new Flag to Addons that indicate "PB-readyness"? 
- "undefined" is the default value which indicates that it is not known whether this Addon honors PB mode restrictions. 
- "pb-safe" indicates that an Addon does not "leak" any information at all or honors a document's PB state. 
- "pb-unsafe" indicates that an Addon does not honor a document's PB state and may "leak" private information. 

Such a flag may provide hints (displayed in about:addons and AMO) for users whether they want to use an Addon when they need to rely on PB information not being leaked at all. This flag can also be added to the AMO review process. Plus, if Fx eventually has the ability to disable Addons per-document, this flag can be used to indicate whether an Addon has to be disabled for PB.
(In reply to comment #8)
> Is it even possible to disable Bootstrapped Addons for certain windows? I guess
> not. 

It is but that is not a good idea since those add-ons are not different from a user's standpoint.

> How about adding a new Flag to Addons that indicate "PB-readyness"? 
> - "undefined" is the default value which indicates that it is not known whether
> this Addon honors PB mode restrictions. 
> - "pb-safe" indicates that an Addon does not "leak" any information at all or
> honors a document's PB state. 
> - "pb-unsafe" indicates that an Addon does not honor a document's PB state and
> may "leak" private information. 
> 
> Such a flag may provide hints (displayed in about:addons and AMO) for users
> whether they want to use an Addon when they need to rely on PB information not
> being leaked at all. This flag can also be added to the AMO review process.
> Plus, if Fx eventually has the ability to disable Addons per-document, this
> flag can be used to indicate whether an Addon has to be disabled for PB.

Private browsing readiness is already on the review check-list for AMO reviewers.
(In reply to :Ehsan Akhgari from comment #9)
> (In reply to comment #8)
> > Is it even possible to disable Bootstrapped Addons for certain windows? I guess
> > not. 
> 
> It is but that is not a good idea since those add-ons are not different from
> a user's standpoint.

I don't see how this is possible. Bootstrapped add-on code is not tied to windows, and many of them use e.g. the window watcher to enumerate windows and run code in them. There's no easy way to stop that.
(In reply to comment #10)
> (In reply to :Ehsan Akhgari from comment #9)
> > (In reply to comment #8)
> > > Is it even possible to disable Bootstrapped Addons for certain windows? I guess
> > > not. 
> > 
> > It is but that is not a good idea since those add-ons are not different from
> > a user's standpoint.
> 
> I don't see how this is possible. Bootstrapped add-on code is not tied to
> windows, and many of them use e.g. the window watcher to enumerate windows and
> run code in them. There's no easy way to stop that.

Oh I thought comment 8 is proposing to disable those add-ons completely without restarting!

To be honest, there is nothing practical to be done in this bug...
See Also: → 761950
Duplicate of this bug: 909771
You need to log in before you can comment on or make changes to this bug.