B2G AutoMounter doesn't deal with out-of-order events

RESOLVED FIXED in Firefox 20

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dhylands, Assigned: dhylands)

Tracking

unspecified
B2G C4 (2jan on)
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:-, firefox20 fixed, b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
In particular, the AutoMounter currently assumes that disk removal/insertion events will be followed by state change events.

It appears that they can occur in the order: state change, disk-insertion (see bug 822465)
(Assignee)

Comment 1

6 years ago
Created attachment 693552 [details] [diff] [review]
Deal with disk insertion event after state change event

This should address the problem seen in bug 822465. Since I can't reproduce, could I get you to try it?
Flags: needinfo?(dwilson)
(Assignee)

Comment 2

6 years ago
Updated flags to match bug 822465
blocking-basecamp: --- → -
tracking-b2g18: --- → +
(Assignee)

Updated

6 years ago
Assignee: nobody → dhylands
(Assignee)

Updated

6 years ago
Attachment #693552 - Flags: review?(kyle)
Attachment #693552 - Flags: review?(kyle) → review+
https://hg.mozilla.org/mozilla-central/rev/1b92a38beffd
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
FYI This seems to work only if I do get root access through |adb root|
Flags: needinfo?(dwilson)
(Assignee)

Comment 6

6 years ago
Sorry, I don't understand. What seems to work?

Or are you saying that the original bug 822465 only manifests when the adb shell is non-root?
(In reply to Dave Hylands [:dhylands] from comment #6)
> Sorry, I don't understand. What seems to work?
> 
> Or are you saying that the original bug 822465 only manifests when the adb
> shell is non-root?

Yes, I had to do an |adb root| on my -userdebug build for the SD card to mount. Although now I'm not sure my build picked up the attached patch. I'll try again tomorrow
https://hg.mozilla.org/releases/mozilla-b2g18/rev/4508594f9323
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-firefox20: --- → fixed
Target Milestone: --- → B2G C4 (2jan on)
You need to log in before you can comment on or make changes to this bug.