Camera - video recording - camera app crashes when switching to/from home screen

RESOLVED DUPLICATE of bug 820139

Status

RESOLVED DUPLICATE of bug 820139
6 years ago
6 years ago

People

(Reporter: mikeh, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

STR:
1. open Camera app
2. switch to video recording mode
3. tap the Start button
4. tap the Stop button
5. tap the Home button
6. tap the Camera icon
7. tap the Start button.

Expected: video should start recording.

Observed: Camera app crashes.
blocking-basecamp: --- → ?
(gdb) c
Continuing.
[New Thread 108.396]
[New Thread 108.402]
[New Thread 108.429]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 108.402]
0x40e302fa in mozilla::GonkRecorderProfile::ConfigureRecorder (this=0x0, aRecorder=0x47f5ed40) at /home/mikeh/dev/mozilla/btg017/gecko/dom/camera/GonkRecorderProfiles.cpp:102
102	  CHECK_SETARG(aRecorder->setOutputFormat(GetOutputFormat()));
(gdb) bt
#0  0x40e302fa in mozilla::GonkRecorderProfile::ConfigureRecorder (this=0x0, aRecorder=0x47f5ed40) at /home/mikeh/dev/mozilla/btg017/gecko/dom/camera/GonkRecorderProfiles.cpp:102
#1  0x40e28f46 in mozilla::nsGonkCameraControl::SetupRecording (this=0x47eacc40, aFd=<value optimized out>, aRotation=90, aMaxFileSizeBytes=3514269696, aMaxVideoLengthMs=0)
    at /home/mikeh/dev/mozilla/btg017/gecko/dom/camera/GonkCameraControl.cpp:1220
#2  0x40e29824 in mozilla::nsGonkCameraControl::StartRecordingImpl (this=0x47eacc40, aStartRecording=0x47f8fb00) at /home/mikeh/dev/mozilla/btg017/gecko/dom/camera/GonkCameraControl.cpp:861
#3  0x40e27ed4 in mozilla::StartRecordingTask::Run (this=0x47f8fb00) at /home/mikeh/dev/mozilla/btg017/gecko/dom/camera/CameraControlImpl.h:442
#4  0x4118b28a in nsThread::ProcessNextEvent (this=0x43f9b6a0, mayWait=<value optimized out>, result=0x4b50beb7) at /home/mikeh/dev/mozilla/btg017/gecko/xpcom/threads/nsThread.cpp:620
#5  0x4116b6a6 in NS_ProcessNextEvent_P (thread=0x47f5ed40, mayWait=true) at /home/mikeh/dev/mozilla/btg017/objdir-gecko/xpcom/build/nsThreadUtils.cpp:220
#6  0x4118b6d4 in nsThread::ThreadFunc (arg=<value optimized out>) at /home/mikeh/dev/mozilla/btg017/gecko/xpcom/threads/nsThread.cpp:258
#7  0x403ab9b0 in _pt_root (arg=<value optimized out>) at /home/mikeh/dev/mozilla/btg017/gecko/nsprpub/pr/src/pthreads/ptthread.c:156
#8  0x400ffe18 in __thread_entry (func=0x403ab951 <_pt_root>, arg=0x4044e9e0, tls=<value optimized out>) at bionic/libc/bionic/pthread.c:217
#9  0x400ff96c in pthread_create (thread_out=<value optimized out>, attr=0xbe9350b4, start_routine=0x403ab951 <_pt_root>, arg=0x4044e9e0) at bionic/libc/bionic/pthread.c:357
#10 0x00000000 in ?? ()
(gdb) 

This looks like what kanru reported in bug 820139 comment 4.  In which case, we now have clear STR for that.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 820139
blocking-basecamp: ? → +
You need to log in before you can comment on or make changes to this bug.