Don't use Java plugin (npjp2.dll) bundled with JavaFX

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
5 years ago
4 months ago

People

(Reporter: Masahiro YAMADA, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Environment: Windows 7 32bit (With All update) , Firefox 19.0.1
JRE 7 update 10
JavaFX 2.1.1 (It contains Java plug-in of JRE 7 update 5)

Oracle added a feature to install of Java FX via auto-update at 7u5 and 7u6, and removed it at 7u6 (At 7u6, Java FX is included in JRE, not another application)

As a result of it , on some user's PC, two plug-ins are installed.

 1. C:\Program Files\Oracle\JavaFX 2.1 Runtime\bin\plugin2\npjp2.dll
 2. C:\Program Files\Java\jre7\bin\plugin2\npjp2.dll 

Auto-update of JRE does not update plugin of Java FX .
As result of it, on some environment, Java plug-in in Java FX is still OLD, even if Java plug-in of JRE.

Expected Result
  When path of npjp2.dll is bundled with JavaFX , don't use it.
  And use plugin bundled with JRE 
Actual Result
  npjp2.dll is already registered to Firefox , Firefox uses it even if plugin in bundled with JRE exists and it is later than plugin bundled with Java FX.
(Reporter)

Updated

5 years ago
Component: General → Java (Oracle)
OS: Windows XP → Windows 7
Product: Firefox → Plugins
Version: 19 Branch → unspecified

Comment 1

5 years ago
The Plugins/Java component is for Oracle's issues in case they monitor those bugs which I doubt.
Component: Java (Oracle) → Plug-ins
Product: Plugins → Core
Duplicate of this bug: 824329
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.