Error: not well-formed in about:home

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
http://hg.mozilla.org/releases/mozilla-release/rev/c23c45132139
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0 ID:20121128204232

Steps to reproduce:
1. Open Error Console
2. Clich home toolbar button

Actual results:
Error: not well-formed
Source File: 
Line: 639, Column: 71
Source Code:
                <!--icon:https://lh6.googleusercontent.com/-varsD8Ng--o/UKVaw32QWII/AAAAAAAAAKs/70M4aSU9JRo/s50/fbmessenger.png-->
could be an issue in the snippet...
Flags: needinfo?(mkelly)
(In reply to Marco Bonardo [:mak] from comment #1)
> could be an issue in the snippet...

Correct! This has been corrected in the offending snippet and I can no longer reproduce. It will take up to 24 hours for the snippet to be redistributed, but you can force a refresh of your snippets by entering `localStorage['snippets-last-update'] = 0` in the JS console on about:home and then refreshing.

Long term this bug will be covered by some in-progress work on a new snippet service.

Winston: The cause of this issue was the Social API icon (shown above) URL: it had `--` in it, which (unfortunately) breaks the validity of the snippet. If you use the icon again, can you reupload it to wherever you upload the icons and check to see there's no `--` in the URL?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mkelly)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.