Closed Bug 823004 Opened 7 years ago Closed 7 years ago

B2G STK: STK Set-Up idle mode doesn't work properly

Categories

(Firefox OS Graveyard :: General, defect, P2)

x86
macOS
defect

Tracking

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

RESOLVED FIXED
B2G C3 (12dec-1jan)
blocking-basecamp +
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: mbarone976, Assigned: vingtetun)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Gecko: cb6ee76
Gaia: 16006ea

Precondition: To perform this test you need the SIM toolkit Kit with the SIM number 10

STR
1. Introduce the SIM number 10
2. In settings go to SIM Toolkit option
3. Wait some seconds

EXPECTED RESULT
The SIM must send the event Profile Download

ACTUAL RESULT
Nothing happens
dpv, can you check it is a certification blocker and if so link to the corresponding bug? If it is a blocker, can we check for extra-information about when this command is used?
Flags: needinfo?(dpv)
Hi, 

Just fyi, with the Set Up Idle Mode Text proactive command the SIM sends a text which will be displayed by the terminal when being in idle mode. 

This is a quite basic STK feature, and it'd be blocker for v1. Adding also dependency... 

Cheers, 
David
Flags: needinfo?(dpv)
blocking-basecamp: ? → +
Keywords: regression
Priority: -- → P2
Target Milestone: --- → B2G C3 (12dec-1jan)
Assignee: nobody → frsela
Hi,

Is something new in settings which avoids the execution of NotificationHelper?

When I execute this code from icc.js:

  function displayNotification(command) {
    var options = command.options;
    NotificationHelper.send('STK', options.text);
  }

I receive this platform error:

E/GeckoConsole(  108): [JavaScript Error: "invalid 'in' operand message" {file: "chrome://browser/content/shell.js" line: 658}]

The same code in dialer or SMS is working well.
Flags: needinfo?(kaze)
Not that I know of, but I never used the NotificationHelper so far so I’m probably not the right person to ask.
Flags: needinfo?(kaze)
NotificationHelper doesn't work on settings app (?). So I moved notifications to the system app (icc_cache.js).

Anyway, I think this is a better approach since we avoid to open settings app only to set a notification into the notification bar when the ICC requires it.
Attachment #694743 - Flags: review?(21)
Comment on attachment 694743 [details] [diff] [review]
Fixed STK notifications. Moved STK notifications to system's ICC JS

Let's fix the real bug in b2g/chrome/content/shell.js instead of moving more code in the System app.
Attachment #694743 - Flags: review?(21) → review-
Attached patch Patch shell.jsSplinter Review
Small fix for shell.js.
Assignee: frsela → 21
Attachment #694743 - Attachment is obsolete: true
Attachment #696058 - Flags: review?(etienne)
Attachment #696058 - Flags: review?(etienne) → review+
Component: Gaia::Settings → General
https://hg.mozilla.org/mozilla-central/rev/8dd9b338324c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.