Intermittent B2G test_execute_script.py TestExecuteContent.test_execute_no_return | EOFError: telnet connection closed (followed by many more)

RESOLVED DUPLICATE of bug 802877

Status

RESOLVED DUPLICATE of bug 802877
6 years ago
6 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
b2g_ics_armv7a_gecko_emulator mozilla-central opt test marionette-webapi on 2012-12-19 04:21:19 PST for push 1b6ab3a080d8

slave: talos-r3-fed-046

https://tbpl.mozilla.org/php/getParsedLog.php?id=18090704&tree=Firefox

{
04:31:26     INFO -  TEST-START test_execute_script.py
04:31:27     INFO -  test_check_window (test_execute_script.TestExecuteChrome) ... ok
04:31:28     INFO -  test_complex_return_values (test_execute_script.TestExecuteChrome) ... ok
04:31:28     INFO -  test_execute_js_exception (test_execute_script.TestExecuteChrome) ... ok
04:31:29     INFO -  test_execute_no_return (test_execute_script.TestExecuteChrome) ... ok
04:31:30     INFO -  test_execute_permission (test_execute_script.TestExecuteChrome) ... ok
04:31:31     INFO -  test_execute_simple (test_execute_script.TestExecuteChrome) ... ok
04:31:32     INFO -  test_sandbox_reuse (test_execute_script.TestExecuteChrome) ... ok
04:31:32     INFO -  test_that_we_can_pass_in_floats (test_execute_script.TestExecuteChrome) ... ok
04:31:33     INFO -  test_check_window (test_execute_script.TestExecuteContent) ... ok
04:31:34     INFO -  test_complex_return_values (test_execute_script.TestExecuteContent) ... ok
04:31:35     INFO -  test_execute_js_exception (test_execute_script.TestExecuteContent) ... ok
04:34:47     INFO -  test_execute_no_return (test_execute_script.TestExecuteContent) ... Android Debug Bridge version 1.0.29
04:34:48     INFO -  'cp' not found, but 'dd' was found as a replacement
04:34:58     INFO -  ERROR
04:34:58     INFO -  test_execute_permission (test_execute_script.TestExecuteContent) ... ERROR
04:34:58     INFO -  test_execute_simple (test_execute_script.TestExecuteContent) ... ERROR
04:34:58     INFO -  test_sandbox_reuse (test_execute_script.TestExecuteContent) ... ERROR
04:34:58     INFO -  test_that_we_can_pass_in_floats (test_execute_script.TestExecuteContent) ... ERROR
04:34:58     INFO -  ======================================================================
04:34:58     INFO -  ERROR: test_execute_no_return (test_execute_script.TestExecuteContent)
04:34:58     INFO -  ----------------------------------------------------------------------
04:34:58    ERROR -  Traceback (most recent call last):
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 140, in tearDown
04:34:58     INFO -      CommonTestCase.tearDown(self)
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 96, in tearDown
04:34:58     INFO -      self.perfdata = self.marionette.get_perf_data()
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 506, in get_perf_data
04:34:58     INFO -      return self._send_message('getPerfData', 'value')
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 214, in _send_message
04:34:58     INFO -      port = self.emulator.restart(self.local_port)
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/emulator.py", line 276, in restart
04:34:58     INFO -      self.start()
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/emulator.py", line 372, in start
04:34:58     INFO -      self.geo.set_default_location()
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/emulator_geo.py", line 13, in set_default_location
04:34:58     INFO -      self.set_location(self.lon, self.lat)
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/emulator_geo.py", line 16, in set_location
04:34:58     INFO -      self.emulator._run_telnet('geo fix %0.5f %0.5f' % (self.lon, self.lat))
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/emulator.py", line 236, in _run_telnet
04:34:58     INFO -      return self._get_telnet_response(command)
04:34:58     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/emulator.py", line 225, in _get_telnet_response
04:34:58     INFO -      line = self.telnet.read_until('\n')
04:34:58     INFO -    File "/usr/lib/python2.6/telnetlib.py", line 319, in read_until
04:34:58     INFO -      return self.read_very_lazy()
04:34:58     INFO -    File "/usr/lib/python2.6/telnetlib.py", line 395, in read_very_lazy
04:34:58     INFO -      raise EOFError, 'telnet connection closed'
04:34:58     INFO -  TEST-UNEXPECTED-FAIL | test_execute_script.py TestExecuteContent.test_execute_no_return | EOFError: telnet connection closed
...
...
}
(Reporter)

Updated

6 years ago
Blocks: 823076
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 802877
You need to log in before you can comment on or make changes to this bug.