Closed Bug 823240 Opened 9 years ago Closed 9 years ago

Include <sys/proc.h> on OpenBSD to get P_TRACED definition

Categories

(Core :: IPC, defect)

x86
OpenBSD
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: gaston, Assigned: gaston)

Details

Attachments

(1 file)

Since rev 1.127 of <sys/sysctl.h> (see http://www.openbsd.org/cgi-bin/cvsweb/src/sys/sys/sysctl.h) <sys/proc.h> is not automatically included when <sys/sysctl.h> is included. Thus build of ipc/chromium/src/base/debug_util_posix.cc fails :

/usr/obj/firefox-18.0beta3/mozilla-beta/ipc/chromium/src/base/debug_util_posix.cc:103:37: error: use of undeclared identifier 'P_TRACED'
  being_debugged = (info.KP_FLAGS & P_TRACED) != 0;

including the missing #include fixes the build.
Assignee: nobody → landry
Attachment #694051 - Flags: review?(jones.chris.g)
Attachment #694051 - Flags: review?(jones.chris.g) → review+
Comment on attachment 694051 [details] [diff] [review]
Include sys/proc.h on OpenBSD

[Approval Request Comment]
Bug caused by (feature/regressing bug #): OpenBSD's r1.127 of sys/sysctl.h
User impact if declined: Local patch to carry on OpenBSD for the next two releases, unhappy maintainer (me)
Testing completed (on m-c, etc.): in progress
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #694051 - Flags: approval-mozilla-beta?
Attachment #694051 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8b94cd856c59
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment on attachment 694051 [details] [diff] [review]
Include sys/proc.h on OpenBSD

Since this is #def'd, we can take this for FF18. Please land as soon as possible, and no later than 12/26 to make it into FF18.
Attachment #694051 - Flags: approval-mozilla-beta?
Attachment #694051 - Flags: approval-mozilla-beta+
Attachment #694051 - Flags: approval-mozilla-aurora?
Attachment #694051 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.