bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Exclude x86 from Google Play

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: tchung, Assigned: akeybl, NeedInfo)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox19+, firefox20+, firefox21+, fennec+)

Details

(Whiteboard: [leave open until we ship x86, or Google fixes themselves])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 694177 [details]
screenshot

This device is finding Firefox and Firefox Beta in Google Play.   However, downloading and installing it will quickly throw the error: 

Package file is invalid.

As expected, since this is a x86 phone.  Should we blocklist this device from Play market?

see screenshot
(Reporter)

Updated

6 years ago
Summary: Blacklist Motorola Droid Razr i from Google Play → Blacklist Motorola Droid Razr i (x86) from Google Play
Would be for every Android x86 out there. I'm really surprised Google Play doesn't do this already.
Summary: Blacklist Motorola Droid Razr i (x86) from Google Play → Filter out (x86) from Google Play
we're not supposed to have to black list:

An application that includes native libraries that target a specific platform (ARM EABI v7 or x86, for example) are visible only on devices that support that platform. For details about the NDK and using native libraries, see What is the Android NDK?

But I also recall seeing something about this being broken.
pdadb.net shows 8 currently shipping Android phones:

Device                    | In play store
==========================|===============
Motorola RAZR i MT788     | No
Motorola RAZR i XT890     | Yes
ZTE Grand X IN P940 16GB  | No
ZTE Grand X IN P940 4GB   | No
ZTE Warp Sequent (n861)   | Yes
Orange Santa Diego        | Yes
Lenovo K800               | Yes
Lava Xolo X900            | Yes

In addition the play store shows a couple more devices that are manufactured by Intel:
Orange avec Intel Inside(AZ210B)
SP-A20i(SP-A20i)
SP-A20i(noonhill)

Everything that is in the play store shows up as compatible with Fennec, so its fairly obvious that the the play store's native library filtering is not working correctly. We should black list all 8 of these until they fix it.
(Assignee)

Updated

6 years ago
Assignee: nobody → akeybl
(Assignee)

Comment 5

6 years ago
I've filtered out

Motorola RAZR i XT890
ZTE Warp Sequent (n861)
Orange Santa Diego
Lenovo K800
Lava Xolo X900
Orange avec Intel Inside(AZ210B)
SP-A20i(SP-A20i)
SP-A20i(noonhill)

for both the Beta and Release products. We'll leave this bug open to check back in future releases.
tracking-firefox19: --- → +
tracking-firefox20: --- → +
Summary: Filter out (x86) from Google Play → Exclude x86 from Google Play
Whiteboard: [leave open until we ship x86, or Google fixes themselves]
tracking-fennec: ? → 19+

Comment 6

6 years ago
Can someone provide a model# and serial # of a phone that reproduces this issue?  Feel free to send it to me in a private message.
Motorola Razr i XT890. However it won't reproduce at this time using Firefox for Android or Firefox Beta in the store since we have explicitly blocked the phones.

Comment 8

6 years ago
Thanks Kevin.  So you added it to a blacklist?  I believe another developer encountered a similar problem when they failed to specify multi-APK in their manifest.  Not sure if that's the situation here, though.
Brad would you provide the details for Mike?
Flags: needinfo?(blassey.bugs)
(In reply to Mike Graboski from comment #8)
> Thanks Kevin.  So you added it to a blacklist?  I believe another developer
> encountered a similar problem when they failed to specify multi-APK in their
> manifest.  Not sure if that's the situation here, though.

Mike, not sure what you mean by specifying multi-APK in the manifest. Can you elaborate?

The problem here is our ARMv7 build (which only ha lisbraries in the lib/armeabi-v7a folder) is being offered to x86 users. Whether or not we have an x86 supporting APK this shouldn't happen.

Google play already properly distinguishes our ARMv7 builds from our generic ARM builds (which get offered to ARMv6 users), so that part is working and we will eventually use that mechanism to offer a build to our x86 users.
Flags: needinfo?(blassey.bugs)

Comment 11

5 years ago
Did someone report this to Google?

Updated

5 years ago
Flags: needinfo?(mgraboski)
bumping tracking to FF21 so this stays on our radar.
tracking-firefox21: --- → +
tracking-fennec: 19+ → +

Comment 13

5 years ago
Following up on Mike's earlier request on information about a phone that this reproduces on -- Can I get a model and serial number?
Comments 7 and 10 cover our known info. Is there something else you need?

Comment 15

5 years ago
You mention that the Motorola Razr i XT890 is now blacklisted and it won't reproduce. Are there any others?
(In reply to kloh from comment #15)
> You mention that the Motorola Razr i XT890 is now blacklisted and it won't
> reproduce. Are there any others?

I've marked it as unblocked on 'Firefox Beta' on Google Play for testing here. Feel free to check for it now.
On my Motorola Razr i Firefox Beta is now discoverable by a search on the Play Store.

Comment 18

5 years ago
Does Firefox 22 Release support Android-x86?
If it does, https://www.mozilla.org/en-US/mobile/22.0/releasenotes/ should be updated.
relnote-firefox: --- → ?
(In reply to Scoobidiver from comment #18)
> Does Firefox 22 Release support Android-x86?

Karen?

> If it does, https://www.mozilla.org/en-US/mobile/22.0/releasenotes/ should
> be updated.
Flags: needinfo?(krudnitski)
I don't think Softvision has run through the suite of test cases yet - Aaron / Kevin, do you know if they have? Otherwise an ETA when they can run through the suite with at least one device?

I also believe that Intel may be blocking us on the GA channel on Play. I'm already working with Intel to find out who has done that (and get them to hand over that control back to us), but I would hate to advertise the fact we have X86 on GA and yet be blocked. Any way of getting that confirmed on our end (while I work with the Intel guys)?
Flags: needinfo?(krudnitski)
(In reply to Karen Rudnitski [:kar] from comment #20)
> I don't think Softvision has run through the suite of test cases yet - Aaron
> / Kevin, do you know if they have? 

They have not, however, I did and have already signed off on the quality of the builds which we assessed during mozilla-beta (Fx22, Beta 4 → 6). I was under the assumption that we were publishing x86 builds tomorrow.
I feel a tad uncomfortable if we haven't performed a test suite once on one x86 device (just to ensure we have covered initial bases). 

Also still need to figure the blocking issue (if they are still blocking us as well) regardless of pushing anything out.
relnote-firefox: ? → ---
We shipped today; whatever x86 devices that were excluded are now unblocked.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.