Address bar scrolling behavior is inconsistent

RESOLVED DUPLICATE of bug 805746

Status

RESOLVED DUPLICATE of bug 805746
6 years ago
6 years ago

People

(Reporter: bram, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: interaction)

(Reporter)

Description

6 years ago
* First, open any page
* Scroll down the page slowly. Notice how the chrome stays on top even though the content moves down correctly
* Scroll down the page fast. Notice how the chrome would move up with the content, but with a lag. Content would first move down, then the chrome would follow
* Scroll up the page slowly. Notice how the content would refuse to show the chrome
* Scroll back down. This time, scroll up the page fast. Notice how the content would give a space for chrome, but the chrome would appear with a lag

Expected behavior:
Address bar ought to always be positioned vertically on top of the content. When the content moves down enough, the Chrome should disappear. When the content moves up to the Chrome, it should be displayed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805746
You need to log in before you can comment on or make changes to this bug.