Duplicated "tscroll" name for tests on graphs server

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: andershol, Assigned: andershol)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Created attachment 694571 [details] [diff] [review]
Fix dublicated pretty_name and missing MozAfterPaint

The tests with the names "tscroll" and "tscroll_paint" (ids 71 and 112) have the same pretty_name "tscroll" on the graphs server. Looking at other "..._paint" tests, the pretty_name for "tscroll_paint" should probably be "tscroll MozAfterPaint".

Also, the test "tscrollr_paint" should probably have its the pretty_name changed from "tscroll Row Major" to "tscroll Row Major MozAfterPaint", and similar for "tscroll.2_paint" (these are the only "..._paint" tests whit no "Paint" in the pretty_name).

Besides applying the patch, this should be fixed in the database:
update tests
  set pretty_name='tscroll MozAfterPaint'
  where name='tscroll_paint';
update tests
  set pretty_name='tscroll 2 MozAfterPaint'
  where name='tscroll.2_paint';
update tests
  set pretty_name='tscroll Row Major MozAfterPaint'
  where name='tscrollr_paint';
(Assignee)

Updated

6 years ago
Attachment #694571 - Attachment is patch: true
(Assignee)

Updated

6 years ago
Attachment #694571 - Flags: review?(rhelmer)
Attachment #694571 - Flags: review?(rhelmer) → review+
(Assignee)

Comment 1

6 years ago
Created attachment 694736 [details] [diff] [review]
Fix dublicated pretty_name and missing MozAfterPaint (with bug id and reviewer)

Only changing the check-in message with bug id and reviewer.
Attachment #694571 - Attachment is obsolete: true
Attachment #694736 - Flags: review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Whiteboard: [for the /graphs/ repository]
Summary: Dublicated "tscroll" name for tests on graphs server → Duplicated "tscroll" name for tests on graphs server
http://hg.mozilla.org/graphs/rev/1411d6d41387
Assignee: nobody → andershol
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [for the /graphs/ repository]
this needs to be deployed to the graph servers, was that done?
(Assignee)

Comment 4

6 years ago
*cough*This would be easy to see if bug 824228 had been accepted.*cough*

Opening http://graphs.mozilla.org/api/test?attribute=short in a browser and searching for '"tscroll' shows that it has not since the pretty_names ('name' in the json) do not contain MozAfterPaint.
(Assignee)

Comment 5

6 years ago
My previous comment could come across a impolite. I am sorry about that.

(In reply to Joel Maher (:jmaher) from comment #3)
> this needs to be deployed to the graph servers, was that done?

What would one do to get it deployed?
(Assignee)

Comment 7

6 years ago
Thank you for the pointer. Filed bug 834853.
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.