Closed Bug 823832 Opened 7 years ago Closed 7 years ago

focus() could not bring up the keyboard

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox19 unaffected, firefox20 fixed, b2g18 fixed)

VERIFIED FIXED
B2G C3 (12dec-1jan)
blocking-basecamp +
Tracking Status
firefox19 --- unaffected
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: rudyl, Unassigned)

References

Details

(Keywords: regression)

STR
===
1. Go to the message (SMS) app. and try to add a new message.

  Expected:
    The keyboard will show up because it is focused.

  Actual:
    No keyboard shows up, and you have to click one of the input to bring up the keyboard.

--
Here is a simple page to test the focus issue,
http://people.mozilla.com/~rlu/test-autofocus/

I think this regression might be caused by Bug 766066.
Yes, I think so.  Commit https://hg.mozilla.org/releases/mozilla-b2g18/rev/2d6b0c741827 makes it so that a focus event no longer invokes this.showKeyboard(target).
Triage: BB+, P2, C3 - regression
blocking-basecamp: ? → +
Priority: -- → P2
Target Milestone: --- → B2G C3 (12dec-1jan)
Renominate. It feels much  better imo - a web site won't be able to make you crazy by showing/hiding the keyboard without the user consent.
blocking-basecamp: + → ?
blocking-basecamp: ? → +
Blocks: 766066
This regression is a side-effect from my workaround for bug 766066.
I backed out bug 766066 from m-c and m-b2g18:

https://hg.mozilla.org/mozilla-central/rev/feb09cb872f1
https://hg.mozilla.org/releases/mozilla-b2g18/rev/78295924efe8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified in 2012/12/23 build from https://releases.mozilla.com/b2g/
Status: RESOLVED → VERIFIED
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
You need to log in before you can comment on or make changes to this bug.