Closed Bug 823924 Opened 7 years ago Closed 7 years ago

WMF backend hardcodes windows system path

Categories

(Core :: Audio/Video, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: jacek, Assigned: jacek)

References

Details

Attachments

(1 file)

Attached patch fixSplinter Review
This is wrong, user may setup system directory to be different than c:\windows\system32. The attached patch simply removes the absolute path and lets LoadLibrary to find required DLLs.

Green on try (together with bug 823921): https://tbpl.mozilla.org/?tree=Try&rev=b53b4aa772a5
Attachment #694838 - Flags: review?(paul)
Duplicate of this bug: 823021
Blocks: 799315
Comment on attachment 694838 [details] [diff] [review]
fix

Review of attachment 694838 [details] [diff] [review]:
-----------------------------------------------------------------

Reading Bug 823021 and the discussion at the end of Bug 799315, I believe this is correct.

Also, the DLLs under system32 and syswow64 are in the KnownDLL list, so a modified DLL dropped in the Firefox directory would not be loaded.
Attachment #694838 - Flags: review?(paul) → review+
https://hg.mozilla.org/mozilla-central/rev/6d66c25f3e41
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.