Closed Bug 823985 Opened 7 years ago Closed 7 years ago

B2G Cairo-linuxgl port depends on "accessible", but not built (ARM-linux)

Categories

(Firefox Build System :: General, defect)

ARM
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 824927

People

(Reporter: prabu, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120209214325

Steps to reproduce:

Building with cairo-linuxgl, for b2g app, has AccessFu dependency, but is not built. This results in xpcshell failure at run-time, and page not being rendered.


Actual results:

Building with backend as cairo-linuxgl, for b2g application, on ARM-linux, has AccessFu dependency, but is not built. This results in xpcshell ( failure at run-time, and page not being rendered. ie, below line fails in shell.js 
Cu.import('resource://gre/modules/accessibility/AccessFu.jsm'); 


Expected results:

Accessfu should be built as a dependency and the required jsm packaged in the final dist folder.
Hardware: x86 → ARM
I could not find cairo-linuxgl, and I am not sure if it is just boottogecko as I have not tested the full b2g OS, hence filing it under core. Please reassign/categorize if inappropriate.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 824927
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.