Intermittent devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Timed out while waiting for: 4 web consoles opened (x2) + a leak)

RESOLVED FIXED in Firefox 20

Status

defect
RESOLVED FIXED
7 years ago
Last year

People

(Reporter: emorley, Assigned: msucan)

Tracking

({intermittent-failure})

Trunk
Firefox 22
x86
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(firefox20 fixed)

Details

Attachments

(4 attachments)

Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-browser-chrome on 2012-12-20 07:14:37 PST for push 5f697a87ec46

slave: talos-r3-w7-021

https://tbpl.mozilla.org/php/getParsedLog.php?id=18132465&tree=Mozilla-Inbound

{
--DOCSHELL 2CD17CD0 == 27 [id = 4153]
--DOCSHELL 240E38A8 == 26 [id = 4147]
--DOCSHELL 240FDA50 == 25 [id = 4127]
--DOCSHELL 240E8EB8 == 24 [id = 4122]
--DOCSHELL 240F65E0 == 23 [id = 4119]
MOZ_EVENT_TRACE sample 1356020567736 3221
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Timed out while waiting for: 4 web consoles opened
Stack trace:
    JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/head.js :: wait :: line 292
    JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/head.js :: <TOP_LEVEL> :: line 302
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
...
...
...
MOZ_EVENT_TRACE sample 1356020569749 2668
WARNING: NS_ENSURE_TRUE(wrapper) failed: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsJSUtils.cpp, line 81
WARNING: NS_ENSURE_TRUE(wrapper) failed: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsJSUtils.cpp, line 81
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Console message: [JavaScript Error: "self.other is undefined" {file: "chrome://global/content/devtools/dbg-transport.js" line: 212}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Console message: [JavaScript Error: "self.other is undefined" {file: "chrome://global/content/devtools/dbg-transport.js" line: 212}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Console message: [JavaScript Error: "this.contentWindow is undefined" {file: "chrome://global/content/devtools/dbg-browser-actors.js" line: 478}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Console message: [JavaScript Error: "this.contentWindow is undefined" {file: "chrome://global/content/devtools/dbg-browser-actors.js" line: 478}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Console message: [JavaScript Error: "attachTab failed: unknownError error occurred while processing 'attach' request: TypeError: this.contentWindow is undefined" {file: "chrome://browser/content/devtools/webconsole.js" line: 4228}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Console message: [JavaScript Error: "attachTab failed: unknownError error occurred while processing 'attach' request: TypeError: this.contentWindow is undefined" {file: "chrome://browser/content/devtools/webconsole.js" line: 4228}]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Timed out while waiting for: 4 web consoles closed
Stack trace:
    JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/head.js :: wait :: line 292
    JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/head.js :: <TOP_LEVEL> :: line 302
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | finished in 14046ms
}
https://tbpl.mozilla.org/php/getParsedLog.php?id=18142473&tree=Mozilla-Inbound
Summary: Intermittent devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Timed out while waiting for: 4 web consoles opened (x2) → Intermittent devtools/webconsole/test/browser_webconsole_bug_595350_multiple_windows_and_tabs.js | Timed out while waiting for: 4 web consoles opened (x2) + a leak)
Mihai, in the last week this has featured pretty highly on OrangeFactor. I don't suppose you could take a look? :-)
Flags: needinfo?(mihai.sucan)
Ed: thanks for the ping! Yes, I noticed this new intermittent failure and it's rather surprising. I will investigate ASAP - this week or next one (holidays).
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
Flags: needinfo?(mihai.sucan)
(In reply to Mihai Sucan [:msucan] from comment #14)
> Ed: thanks for the ping! Yes, I noticed this new intermittent failure and
> it's rather surprising. I will investigate ASAP - this week or next one
> (holidays).

Thank you :-)
A quick update: there's still stuff going on with the toolbox. We are still changing things related to init/destroy. This bug might solve itself when things settle down. If it does not, I will investigate this particular issue. If I forget about the bug, please ping me. Thanks!
Great - thank you for the update :-)
While working on a different Web Console patch I bumped into this test. I noticed why these intermittent failures happen: notice that it waits for 4 consoles to open, then 4 consoles to close. The second check doesn't fail. I think the consoles open, but they take too long and timeout kicks-in after 5 seconds. Close doesn't timeout.

I'll probably increase the timeout.
This is hopefully going to be fixed by Bug 827083. I've doubled the timeout for the web console open.
Depends on: 827083
Attachment #703839 - Flags: review?(past)
Comment on attachment 703839 [details] [diff] [review]
patch for aurora

Review of attachment 703839 [details] [diff] [review]:
-----------------------------------------------------------------

OK.
Attachment #703839 - Flags: review?(past) → review+
Comment on attachment 703839 [details] [diff] [review]
patch for aurora

Thank you Panos!

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a. this seems to be a regression caused by the toolbox landing, bug 788977 - web console opening and closing is slower, causing timeouts.
User impact if declined: continued oranges in aurora.
Testing completed (on m-c, etc.): local testing, but I also did a similar fix for m-c and it seems to work.
Risk to taking this patch (and alternatives if risky): no risk. the alternative is to disable the test.
String or UUID changes made by this patch: none.

Thank you!
Attachment #703839 - Flags: approval-mozilla-aurora?
This patch hopefully fixes the deactivateHUDForContext() test leak.

Try push:
https://tbpl.mozilla.org/?tree=Try&rev=cd568e567e3d
Attachment #703850 - Flags: review?(past)
Comment on attachment 703850 [details] [diff] [review]
patch for aurora: fix for leak in deactivateHUDForContext test

Review of attachment 703850 [details] [diff] [review]:
-----------------------------------------------------------------

Good idea.
Attachment #703850 - Flags: review?(past) → review+
Comment on attachment 703850 [details] [diff] [review]
patch for aurora: fix for leak in deactivateHUDForContext test

Thank you Panos!

[Approval Request Comment]
Bug caused by (feature/regressing bug #): might be caused by the toolbox landing, but this is a failure specific to the aurora repository. The test waits for a potentially flimsy notification that fires slightly too early inside the web console (issue fixed in m-c). On slow machines finishing the test too early might cause memleaks.
User impact if declined: continued oranges in aurora repo.
Testing completed (on m-c, etc.): local testing and try push: https://tbpl.mozilla.org/?tree=Try&rev=cd568e567e3d
Risk to taking this patch (and alternatives if risky): minimal risks, alternative is to disable the test.
String or UUID changes made by this patch: none.

Thank you!
Attachment #703850 - Flags: approval-mozilla-aurora?
Attachment #703850 - Flags: approval-mozilla-aurora?
Attachment #703839 - Flags: approval-mozilla-aurora?
It seems the two attempted fixes did not work on aurora. To get the tests running properly we probably need more fixes from m-c - for the web console and maybe for the toolbox.

I, Panos and Ehsan agreed to disable the offending tests:

https://hg.mozilla.org/releases/mozilla-aurora/rev/a8d6394508a3

Apologies to all for the trouble.
Another very good possibility is that testpilot just makes you leak, and either you need it fixed, or you need a separate fix which does not exist on mozilla-central either to deal with the things it does without leaking.
I suppose that can be verified just pushing mozilla-inbound code to try with aurora update channel hack, if it fails it's not pgo, nor it's fixed in central
Blocks: 832703
https://tbpl.mozilla.org/?tree=Try&rev=43195caceb56 says, yeah, central+testpilot leaks 'em too.
This intermittent failure is still happening quite often.

As discussed this patch (hopefully) fixes the "4 web consoles closed" intermittent failure, by increasing the timeout. It seems this approach worked for the "4 web consoles opened" intermittent failure.

Please review and I'll land it in inbound.
Attachment #721826 - Flags: review?(past)
Comment on attachment 721826 [details] [diff] [review]
increase timeout for "4 web consoles closed"

Review of attachment 721826 [details] [diff] [review]:
-----------------------------------------------------------------

OK.
Attachment #721826 - Flags: review?(past) → review+
https://hg.mozilla.org/mozilla-central/rev/99370053542a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.