Closed Bug 824290 Opened 9 years ago Closed 9 years ago

Arrow panels anchored too close to the edge of the screen have their anchor points flipped.

Categories

(Core :: XUL, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mconley, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR (using a recent Nightly on any platform)

1) Customize the Nightly navigation bar, and move the Downloads button to the right-most position.
2) Maximize the window. The Downloads button should now be very close to the edge of the screen.
3) Click on the Downloads button to open the panel.

What happens?

The panel opens, but the arrow is on the *left* side of the panel, far away from the button.

What's expected?

The panel arrow is supposed to be anchored on the button.
Hm - I had mentioned that this is true on "any platform", but on OSX, there's really no such thing as a maximized window.

So let's take OSX out of the group. I can easily reproduce it on Windows and Ubuntu.
Here's the screenshot that the original bug reporter showed me.
(In reply to Mike Conley (:mconley) from comment #1)
> Hm - I had mentioned that this is true on "any platform", but on OSX,
> there's really no such thing as a maximized window.
> 
> So let's take OSX out of the group. I can easily reproduce it on Windows and
> Ubuntu.

Nevermind, just reproduced on OSX without much trouble.
Bug 798226 and bug 821283 are currently my top suspects.
Duplicate of this bug: 824385
Fixed by backing the patch out.

https://hg.mozilla.org/integration/mozilla-inbound/rev/c454966ef45c
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Component: XP Toolkit/Widgets: Menus → XUL
You need to log in before you can comment on or make changes to this bug.