bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[CSS3] weird outline behaviour on transform with transition

VERIFIED FIXED in mozilla30

Status

()

Core
General
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: Florian Bender, Assigned: dbaron)

Tracking

18 Branch
mozilla30
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by Bug 480888?])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 695266 [details]
Test-case. Hover over central element to trigger the transform.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121212073002

Steps to reproduce:

Rotate-transform an element that has an outline using a transition. 


Actual results:

The outline did not rotate. The size of the outline "box" changed arbitrarily, i. e. sometimes not even to its child's max size but much larger than that. 

When I removed the transition, the outline rotated alongside its box and did not change its size. 


Expected results:

The outline should rotate along with its element. Meanwhile, it should not change its size.
Attachment #695266 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 1

5 years ago
Possibly related to bug 480888? Have to see …
Depends on: 480888
(Reporter)

Comment 2

5 years ago
Still an issue in Nightly 27.0a1 (2013-10-17).
Might be fixed by bug 480888, but haven't tested yet.
(Reporter)

Comment 4

5 years ago
Yep, looks like that. Thanks!

(I'm trying to cross-check with Aurora though the testcase does not seem to load … odd. Anyway, will update if there's anything amiss.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by Bug 480888?]
Assignee: nobody → dbaron
Target Milestone: --- → mozilla30
QA Whiteboard: [good first verify]
(Reporter)

Comment 5

4 years ago
Testcase verified working as expected in Nightly 31.0a1 (2014-04-28) and Aurora 30.0a2 (2014-04-28).

Testcase fails on Fx29 Release.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.