[Tablet] - Regression: about:home thumbnails are cut off; missing promo banner in landscape orientation

VERIFIED FIXED in Firefox 20

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
11 months ago

People

(Reporter: aaronmt, Assigned: sriram)

Tracking

({regression, reproducible})

unspecified
Firefox 21
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox18 unaffected, firefox19 affected, firefox20 verified, firefox21 verified, relnote-firefox +, fennec19+)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 695488 [details]
Nightly (12/24) - Screenshot

See screenshot

---
Nightly (12/24)
Asus Transformer Prime TF201 (Android 4.0.4)
(Reporter)

Comment 1

5 years ago
Created attachment 695489 [details]
Nightly (12/24) - Screenshot (Portrait)

Portrait is fine; landscape issue.
(Reporter)

Updated

5 years ago
Summary: [Tablet] - Regression: about:home thumbnails are cut off; missing promo banner → [Tablet] - Regression: about:home thumbnails are cut off; missing promo banner in landscape orientation
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 20+
Hmm.. I can't repro this on my Galaxy Tab 10.1. Are you doing anything fancy? Starting in portrait then switching to landscape, or vice versa?
I cannot reproduce on Asus Transformer EEE (Android 4.0.4) using Nightly 20.0a1 (2013-01-07)
Created attachment 700788 [details]
screenshot on Xoom with tab sidebar

I can reproduce this intermittently on my Motorola Xoom Wi-Fi (Android 4.1).  I also frequently get a layout like this attachment, where the marketplace promo banner is weirdly squashed.  This variant happens only when the tab sidebar is visible.  Or sometimes the tabs are not cut off (or barely cut off) but the marketplace banner is completely gone.

As far as I can tell, Firefox 18 Beta is not affected, but Firefox 19 Aurora is.
Attachment #700788 - Attachment is patch: false
Attachment #700788 - Attachment mime type: text/plain → image/png
tracking-fennec: 20+ → 19+
status-firefox18: --- → unaffected
status-firefox19: --- → affected
(Reporter)

Updated

5 years ago
Duplicate of this bug: 830442
(Reporter)

Comment 6

5 years ago
Brad ran into this too in the dupe above.
(Reporter)

Comment 7

4 years ago
STR:

Rotate from portait to landscape
Assignee: lucasr.at.mozilla → sriram
(Reporter)

Updated

4 years ago
Duplicate of this bug: 839482
(Reporter)

Comment 9

4 years ago
This is now
status-firefox21: --- → affected
(Reporter)

Comment 10

4 years ago
(too late for 19 I think)
(Reporter)

Comment 11

4 years ago
Steps for the TF201

i) Open Fennec in landscape
(Assignee)

Comment 12

4 years ago
Is there a regression range?
(Assignee)

Comment 13

4 years ago
Created attachment 713149 [details] [diff] [review]
Patch

There's a condition to try and return the attribute "columnWidth" 's value if its running a version above 16. However, no attribute is specified in XML. Hence the value will be 0dp, this will cause the height to be shrunk while calculating the heightMeasureSpec.
Attachment #713149 - Flags: review?(wjohnston)
Comment on attachment 713149 [details] [diff] [review]
Patch

Review of attachment 713149 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/AboutHomeContent.java
@@ +789,5 @@
>              return getColumnWidth(getWidth());
>          }
>  
>          public int getColumnWidth(int width) {
> +            return (width - getPaddingLeft() - getPaddingRight()) / mNumberOfCols;

Cool. Can you add a note that super.getColumnWidth() doesn't always return the correct thing on all devices (because it seems to work on everything I have that's 16+).
Attachment #713149 - Flags: review?(wjohnston) → review+
(Assignee)

Comment 15

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/edea345c7c6b
(Assignee)

Comment 16

4 years ago
Comment on attachment 713149 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Old code with a check for 16.
User impact if declined: Thumbnails will be cut off.
Testing completed (on m-c, etc.): Landed on m-i just now.
Risk to taking this patch (and alternatives if risky): None. The "else" part works everywhere else and been tested a lot. Now we are making it the default.
String or UUID changes made by this patch: None.
Attachment #713149 - Flags: approval-mozilla-beta?
Attachment #713149 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/edea345c7c6b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21

Updated

4 years ago
Keywords: regressionwindow-wanted
Comment on attachment 713149 [details] [diff] [review]
Patch

We're not taking any new changes on beta at this point since we're about to release and this is not a release-blocking issue so only approving for Aurora.
Attachment #713149 - Flags: approval-mozilla-beta?
Attachment #713149 - Flags: approval-mozilla-beta-
Attachment #713149 - Flags: approval-mozilla-aurora?
Attachment #713149 - Flags: approval-mozilla-aurora+

Updated

4 years ago
status-firefox21: affected → fixed
(Assignee)

Comment 19

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/53a7311047ef

Updated

4 years ago
status-firefox20: affected → fixed
(Reporter)

Comment 20

4 years ago
Quite a visible known-issue on tablets; rel-note for 19?
Status: RESOLVED → VERIFIED
status-firefox20: fixed → verified
status-firefox21: fixed → verified
(Reporter)

Comment 21

4 years ago
^
Flags: needinfo?(bbajaj)
relnote-firefox: --- → ?
(Reporter)

Updated

4 years ago
Flags: needinfo?(bbajaj)

Updated

4 years ago
relnote-firefox: ? → +
You need to log in before you can comment on or make changes to this bug.