Closed Bug 824577 Opened 8 years ago Closed 8 years ago

about:telemetry addon histogram section not displayed

Categories

(Toolkit :: Telemetry, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla20
Tracking Status
firefox19 --- verified
firefox20 --- verified

People

(Reporter: vladan, Assigned: vladan)

Details

Attachments

(1 file)

There is a bug in the code I wrote for iterating over the addon histogram snapshot. The attached patch fixes it.
Attachment #695565 - Flags: review?(mak77)
Attachment #695565 - Flags: review?(mak77) → review+
Comment on attachment 695565 [details] [diff] [review]
Iterate over addon names before iterating over histograms

https://hg.mozilla.org/integration/mozilla-inbound/rev/58edc998ee4f
Attachment #695565 - Flags: checkin+
Comment on attachment 695565 [details] [diff] [review]
Iterate over addon names before iterating over histograms

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 661881
User impact if declined: "Addon Histograms" section of the new about:telemetry page will be empty
Testing completed (on m-c, etc.): Tested locally on m-c and aurora branches
Risk to taking this patch (and alternatives if risky): Very small. This patch changes 10 lines of JavaScript inside the about:telemetry page. In the worst case, if there is a bug that results in an exception being thrown, a couple of sections in the about:telemetry page will be empty.
String or UUID changes made by this patch: None
Attachment #695565 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/58edc998ee4f
Assignee: nobody → vdjeric
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Attachment #695565 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified Fixed on FF 19b1 on Windows 7 x64. Histograms section from about:telemetry works as expected. It displays all data as it should.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0(20130109111322)
Verified Fixed on FF 19b2 too on Ubuntu x86.
(In reply to MarioMi from comment #6)
> Verified Fixed on FF 19b2 too on Ubuntu x86.

Verifed Fixed on Latest Aurora too:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130122 Firefox/20.0(20130122042017)
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130123 Firefox/20.0(20130123042017)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130123 Firefox/20.0(20130123042017)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.