Closed Bug 824634 Opened 7 years ago Closed 7 years ago

fix some ways to crash in OnPaint

Categories

(Core :: Widget: Win32, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox19 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

When the nsAutoScriptBlocker exits in nsViewManager::Refresh we can run script because we add a script runner for the after paint event when we paint (otherwise we shouldn't have anything because we flush before painting in WillPaint). There are some things we can do in OnPaint to make it safe for this. This is just some, there is more yet to do.
Attached patch patch (obsolete) — Splinter Review
Attachment #695651 - Flags: review?(jmathies)
Attached patch patchSplinter Review
Attachment #695651 - Attachment is obsolete: true
Attachment #695651 - Flags: review?(jmathies)
Attachment #695662 - Flags: review?(jmathies)
Attachment #695662 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/2cab642a3317
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment on attachment 695662 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unsure
User impact if declined: some crashes during painting
Testing completed (on m-c, etc.): on nightly for several days
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #695662 - Flags: approval-mozilla-aurora?
Attachment #695662 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.