Closed Bug 824654 Opened 7 years ago Closed 7 years ago

e:/builds/moz2_slave/m-cen-w64/build/layout/style/nsCSSParser.cpp(5698) : error C2079: 'compound' uses undefined class '`anonymous-namespace'::CSSParserImpl::nsAutoParseCompoundProperty'

Categories

(Core :: CSS Parsing and Computation, defect)

x86_64
Windows 8
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

(Keywords: regression)

Attachments

(2 files)

Duplicated nsAutoParseCompoundProperty definition causes bustage on Win64 builder.  Although this is tier-3 platform, we should fix this.

https://tbpl.mozilla.org/php/getParsedLog.php?id=18239760&tree=Firefox&full=1#error0

e:/builds/moz2_slave/m-cen-w64/build/layout/style/nsCSSParser.cpp(5698) : error C2079: 'compound' uses undefined class '`anonymous-namespace'::CSSParserImpl::nsAutoParseCompoundProperty'

e:/builds/moz2_slave/m-cen-w64/build/layout/style/nsCSSParser.cpp(5698) : error C2440: 'initializing' : cannot convert from '`anonymous-namespace'::CSSParserImpl *const ' to 'int'
Attached patch fixSplinter Review
we should remove duplicated define.
Attachment #695697 - Flags: review?(cam)
Comment on attachment 695697 [details] [diff] [review]
fix

Maybe I meant to write nsAutoFailingSupportsRule?  I guess that class didn't need to be a friend of CSSParserImpl in the first place.
Attachment #695697 - Flags: review?(cam) → review+
Comment on attachment 695697 [details] [diff] [review]
fix

The second instances was meant to be nsAutoFailingSupportsRule, I think.
Attachment #695697 - Flags: review+ → review?(cam)
So I'm not actually sure why nsAutoFailingSupportsRule doesn't need to be a friend of CSSParserImpl, given it touches the latter's protected mInFailingSupportsRule member.
Because |friend|-ness of nested classes is implied in C++2011 (and was implemented well before 2011), even though it was not implied in C++1998.  So the friend declaration may well be needed for correct C++1998 compilers.
Anyway, I didn't mean to remove the review+, though I think you should probably change it to what was intended rather than removing it.
Comment on attachment 695697 [details] [diff] [review]
fix

OK, let's add the friend declaration back in then.
Attachment #695697 - Flags: review?(cam) → review+
Attached patch fix v2Splinter Review
back nsAutoFailingSupportsRule define.
Attachment #695699 - Flags: review?(cam)
Attachment #695699 - Flags: review?(cam) → review+
https://hg.mozilla.org/mozilla-central/rev/18a3309af87e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.