crash in mozilla::MediaCache::GetBlockOwner

RESOLVED FIXED in mozilla21

Status

()

Core
Audio/Video
--
critical
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Matti, Assigned: cpearce)

Tracking

({crash})

Trunk
mozilla21
x86
Windows 7
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-e09f7ee7-0b84-4fd0-8221-c124b2121227 .
============================================================= 

I crash twice while loading the URL http://slides.html5rocks.com/ .
The crashes occurred directly after loading the page but unfortunately I can not reproduce the crash at the moment :-(

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17a1
Build identifier: 20121224003038

Note: I have h264 playback enabled
(Reporter)

Updated

6 years ago
Crash Signature: [@ mozilla::MediaCache::GetBlockOwner(int, mozilla::MediaCacheStream*)] → [@ mozilla::MediaCache::GetBlockOwner(int, mozilla::MediaCacheStream*) ]
(Reporter)

Updated

6 years ago
Duplicate of this bug: 825446
(Reporter)

Comment 2

6 years ago
The URL from the duplicate bug: http://hepster.ru:8000/play

Updated

5 years ago
Crash Signature: [@ mozilla::MediaCache::GetBlockOwner(int, mozilla::MediaCacheStream*) ] → [@ mozilla::MediaCache::GetBlockOwner(int, mozilla::MediaCacheStream*)]
Blocks: 799315
(Assignee)

Comment 3

5 years ago
OK, the problem is pretty straightforward; the stream isn't seekable, so we're returning -1 to WMF in WMFByteStream::GetLength(). WMF is then trying to seek to that offset, not realising that it's invalid, and WMF ends up requesting a read with a negative offset.

If we report to WMF in WMFByteStream::GetCapabilities() that the stream is not as easily seekable when the length is -1 we seem to avoid this chain of events.
Assignee: nobody → cpearce
(Assignee)

Updated

5 years ago
Depends on: 836927
(Assignee)

Comment 4

5 years ago
WFM now, fixed by bug 836927.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Target Milestone: --- → mozilla21
Duplicate of this bug: 869632
You need to log in before you can comment on or make changes to this bug.