Closed Bug 824917 Opened 7 years ago Closed 7 years ago

Some WebIDL element interfaces need hasInstanceInterface crud

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

Attachments

(1 file)

Specifically, we have mxr hits (m-c, especially mobile, or addons) on instanceof with the following RHS values that are WebIDL inteface objects where it looks like the LHS might be web content:

  HTMLBodyElement
  HTMLDivElement
  HTMLFrameSetElement
  HTMLHeadingElement
  HTMLLabelElement
Assignee: nobody → bzbarsky
Whiteboard: [need review]
Attachment #696439 - Flags: review?(peterv) → review+
http://hg.mozilla.org/integration/mozilla-inbound/rev/a91661eed949
Flags: in-testsuite+
Whiteboard: [need review]
Target Milestone: --- → mozilla20
Duplicate of this bug: 825743
https://hg.mozilla.org/mozilla-central/rev/a91661eed949
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.