Extra font size tag added after typing a line break and text

RESOLVED WORKSFORME

Status

()

Core
Editor
--
minor
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

({regression})

16 Branch
mozilla21
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Steps to reproduce problem:
1. Change the font size
2. Type some text
3. Hit Enter
4. Type some more text

Expected result: <body><font size="+1">some text<br>some more text</font></body>

Actual result: <body><font size="+1">some text<br><font size="+1">some more text</font></font></body>

Alternative steps to reproduce problem:
1. Select some text
2. Change its font size
3. Click in the middle of the text
4. Hit Enter
5. Type more

Expected result: <body><font size="+1">some<br>more text</font></body>

Actual result: <body><font size="+1">some<br><font size="+1">more</font> text</font></body>

Additional information: Problem does not occur if CSS styles are used.

Comment 1

5 years ago
Regression window(m-c):
Good:
http://hg.mozilla.org/mozilla-central/rev/3b86eaa02d91
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120518080514
Bad:
http://hg.mozilla.org/mozilla-central/rev/17422a2d0c70
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120518104452
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3b86eaa02d91&tochange=17422a2d0c70


Regression window(m-i):
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/11780e80c8c3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120517220915
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e8ebc8f1825e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120517232316
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=11780e80c8c3&tochange=e8ebc8f1825e

Suspected : Bug 590640
Blocks: 590640
Keywords: regressionwindow-wanted
Version: unspecified → 16 Branch
The suspected bug looks plausible, since it was a significant refactor.    I don't have time to do much hacking now, though, and have a pile of bugs already that I'm not clearing away right now as it stands, so I can't take this right now.

Our <font size> handling is horrible as it stands, so I don't find this bug especially surprising.  I suspect it's restricted to <font size> in non-CSS mode; there are lots of bugs there.  Other types of tags probably work just fine.

Comment 3

4 years ago
I know this is still affecting Gecko 19+ as well, is there anything I can do to help progress this?
(Reporter)

Comment 4

4 years ago
This got fixed when bug 812638 backed out part 6 of bug 480647.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.