Full-page invalidation when scrolling on thinkgeek

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sicking, Assigned: mattwoodrow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Steps to reproduce:

1. Go to http://www.thinkgeek.com/product/e845/
2. Enable paint flashing
3. Scroll

Scrolling is pretty slow which likely depends on us invalidating the full page on every scroll.

This looks like a dlbi regression since it doesn't happen in FF17.

I can reproduce this *without* any addons or persona enabled. It's fully reproducible here.

I'm using a new macbook pro with retina display and OSX 10.8.2 on a up-to-date nightly (2012-12-27)
Blocks: 539356
Confirmed on Windows 7 too, no matter if HWA on/off.
Assignee: nobody → matt.woodrow
(Assignee)

Comment 2

5 years ago
I can't reproduce whole page repainting.

With accelerated layers we repaint the area covered by the fixed-position background image, which is expected.

Without accelerated layers we do the same, but also repaint the area of the fixed position footer. Also expected, since we can't retain the footer separately here.
(In reply to Matt Woodrow (:mattwoodrow) from comment #2)
> I can't reproduce whole page repainting.
> 
> With accelerated layers we repaint the area covered by the fixed-position
> background image, which is expected.

They seem to have changed the background. I think they used to have a fixed position background which covered the whole height of the page. So if it's expected that that repaints the whole page then I think this is working as expected.

> Without accelerated layers we do the same, but also repaint the area of the
> fixed position footer. Also expected, since we can't retain the footer
> separately here.

I don't have a fixed position footer on that page.

Anyhow, it sounds like this bug is INVALID if expected behavior is to repaint everything which is covered by a fixed position background.
(Assignee)

Comment 4

5 years ago
Just to be clear, this is only the case when the fixed-position background is attached to something other than the css canvas.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.