Closed Bug 82513 Opened 23 years ago Closed 23 years ago

middle mouse click on scrollbar in editors will paste

Categories

(Core :: DOM: Editor, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 70698
mozilla1.0

People

(Reporter: spam, Assigned: kinmoz)

References

Details

(Keywords: dataloss, Whiteboard: [behavior])

Attachments

(1 file)

seeing with current CVS, but this is an old one. Can't find an original..
--
Open Composer with a page long enough to provide a scrollbar
Select some text somewhere down the page
Now middle-click on scrollbar

Result:
The click will first produce a scroll, then the view snaps back to it's 
original position, and a paste is performed instead. Repeat clicking and you
repeat scroll/snap back/paste - each time.

Expected:
Composer's scrollbar should act like scrollbar in browser, history window,
sidebar etc. and only scroll thumb to center of the location i clicked

This on occation has caused me data corruption, when i didn't realize i had
pasted instead of scrolled. (In particular happens when i haven't yet clicked in
composer page earlyer: When no insertion point yet exists, the paste lands on
top of page, but the view "snaps back" so quick that it's hard to see the paste
takes place. At first i thought it was only the scrolling that was horked.

The same phenomena happens in Bugzilla's comment form and mail-compose
off to kin
Assignee: beppe → kin
Priority: -- → P3
Whiteboard: [behavior]
Target Milestone: --- → mozilla0.9.2
Target Milestone: mozilla0.9.2 → mozilla1.0
*** Bug 89553 has been marked as a duplicate of this bug. ***
Just some more comments (from bug #89553):

This affects the complete scrollbar area (including the directional arrows
and the thumb - you need to double click on the thumb to see this), for both
the horizontal and vertical scrollbars.
This does *not* happen in Bugzilla's comment form for me, instead bug #89238
is triggered, which may be related to this bug.

System information:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628
Build-ID: 2001062823 (this is the 0.9.2 release)
related is bug 70698
dup


*** This bug has been marked as a duplicate of 70698 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
doesn't seem like a dup to me. In this bug the text pastes into top of the the
real editor field after performing a quick scroll up and down. In bug 70698 the
paste appears IN the slider or arrows, as if they are independant little
editors. Attaching screenshot of how bug 70698 looks. It's very different.
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: