Intermittent testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5 or got 2, expected 5

RESOLVED DUPLICATE of bug 769919

Status

()

defect
RESOLVED DUPLICATE of bug 769919
7 years ago
6 years ago

People

(Reporter: jdm, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=18311229&tree=Mozilla-Inbound
Android Armv6 Tegra 250 mozilla-inbound opt test robocop on 2012-12-27 22:25:37 PST for push 3114517c141a

slave: tegra-232



6 INFO TEST-UNEXPECTED-FAIL | testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5
junit.framework.AssertionFailedError: 6 INFO TEST-UNEXPECTED-FAIL | testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5
7 INFO TEST-UNEXPECTED-FAIL | testAllPagesTab | Exception caught - junit.framework.AssertionFailedError: 6 INFO TEST-UNEXPECTED-FAIL | testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5

0 INFO SimpleTest START
1 INFO TEST-START | testAllPagesTab
2 INFO TEST-PASS | testAllPagesTab | Awesomebar URL typed properly - http://mochi.test:8888/tests/robocop/robocop_big_link.html should equal http://mochi.test:8888/tests/robocop/robocop_big_link.html
3 INFO TEST-PASS | testAllPagesTab | Three tabs shown - 3 should equal 3
4 INFO TEST-PASS | testAllPagesTab | Strip is hidden - false should equal false
5 INFO TEST-PASS | testAllPagesTab | checking that all pages list exists - android.widget.ListView@48482d60 should not equal null
6 INFO TEST-UNEXPECTED-FAIL | testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5
Exception caught during test!
junit.framework.AssertionFailedError: 6 INFO TEST-UNEXPECTED-FAIL | testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5
	at junit.framework.Assert.fail(Assert.java:47)
	at org.mozilla.fennec.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:107)
	at org.mozilla.fennec.FennecMochitestAssert.ok(FennecMochitestAssert.java:136)
	at org.mozilla.fennec.FennecMochitestAssert.is(FennecMochitestAssert.java:142)
	at org.mozilla.fennec.tests.testAllPagesTab.testList(testAllPagesTab.java:75)
	at org.mozilla.fennec.tests.testAllPagesTab.testAllPagesTab(testAllPagesTab.java:55)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.fennec.tests.BaseTest.runTest(BaseTest.java:125)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
7 INFO TEST-UNEXPECTED-FAIL | testAllPagesTab | Exception caught - junit.framework.AssertionFailedError: 6 INFO TEST-UNEXPECTED-FAIL | testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5
8 INFO TEST-END | testAllPagesTab | finished in 35339ms
Comment hidden (Legacy TBPL/Treeherder Robot)
Summary: Intermittent testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5 → Intermittent testAllPagesTab | all pages list has 5 children (the default bookmarks) - got 1, expected 5 or got 2, expected 5
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
testAllPagesTab fails at least once a day, one way or another (see also bug 817899 and bug 819419) . It needs attention, but no one seems to have time right now...test disabled:

https://hg.mozilla.org/integration/mozilla-inbound/rev/533a01077116
Whiteboard: [test disabled][leave open]
I would expect bug 798683 to cause failures like this on some device types, where the resolution is such that not all items are visible. As I recall, all 5 items are visible on the tegras, and these failures are intermittent, so I don't think bug 798683 explains this bug.

Still...it would be nice to resolve bug 798683 -- one less possibility.
Did this happen in TRY?
Results will be displayed on TBPL as they come in:
https://tbpl.mozilla.org/?tree=Try&rev=5f892b3d0b87

Once completed, builds and logs will be available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kshriram18@gmail.com-5f892b3d0b87
Try run for 5f892b3d0b87 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=5f892b3d0b87
Results (out of 39 total builds):
    exception: 32
    success: 2
    failure: 5
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kshriram18@gmail.com-5f892b3d0b87
Try run for 4decb04bf434 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=4decb04bf434
Results (out of 261 total builds):
    exception: 101
    success: 155
    failure: 5
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kshriram18@gmail.com-4decb04bf434
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [test disabled][leave open]
Duplicate of bug: 769919
You need to log in before you can comment on or make changes to this bug.