Shared videos directly on Facebook are not correctly supported - ANDROID

RESOLVED FIXED

Status

Tech Evangelism
Mobile
P1
major
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: AdrianT, Assigned: Colby Rabideau)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(firefox18 affected, firefox19 affected, firefox20 affected, firefox21 affected, firefox22 affected, firefox23 affected, firefox24 affected, firefox25 affected, firefox26 affected, firefox27 affected, fennec-)

Details

(Whiteboard: [webcompat][serversniff][sitewait] [country-all], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 696242 [details]
logs

Firefox Mobile 18 beta 6 / Nightly 20.0a1 2012-12-27
Asus EEE Transformer TF101 (Android 4.0.3)

Steps to reproduce:
1) Share a video directly on Facebook (don't share a youtube video)
Alternatively go to facebook.com/ClujCrusaders and scroll down the "Wall" tab until you reach the video
2) Try to open the video from Firefox Mobile

Expected results:
The video is correctly displayed
When the user taps on the video the video is played

Actual results:
The video is not correctly displayed on the "Wall".
When the user taps on the video a pop-up blocker doorhanger is displayed. If you allow it to be shown a new tab with a redirect link is opened but the tab remains blank.
Regardless if the user allows or not the popup each time the user taps on the video a new doorhanger is displayed but the number of pop-ups grows with each tap

Note:
Please see the videocapture: http://youtu.be/W9LyvbBThHg
Keywords: qawanted, steps-wanted
The video plays in the pop up that you're not showing.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted, steps-wanted
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

6 years ago
Brad on what devices/builds did this work for you?

I have retested this on both Firefox Mobile 18.0b7 and Nightly 20.0a1 2013-01-04 on the Asus EEE Transformer TF101 (Android 4.0.3), Acer Iconia A500 (Android 3.1) and on the Samsung Galaxy S2 (Android 4.0.2) and on non of the devices did the video play. On the Tablets the behavior described in Comment 0 is still reproducible - the tab is opened but just a redirect is opened and the video is never played. On the Samsung Galaxy S2 tapping on the play icon does not have any effect at all.

On the Stock Browser the video is played in the video player on the Samsung Galaxy S2 and the Asus EEE Transformers while on the Acer Iconia the Desktop version of the website is displayed.
Status: RESOLVED → REOPENED
Keywords: qawanted, steps-wanted
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

6 years ago
And also a secondary issue that I did not emphasize in comment 2 is that when opening the video the second time 2 pop-ups are displayed, on the 3rd opening 3 and so on each new opening of the video will spawn the previous number of openings + 1 pop-ups
(Reporter)

Comment 4

6 years ago
I have investigated this further and this is what I have found:

Steps to reproduce:
1) Share a video file on a test Facebook account
2) While being signed in to Facebook on a device go directly to the account URL:
   for e.g. facebook.com/Test_account
3) Tap on the Play icon

Actual:
A pop-up blocker doorhanger appears asking to open the video in a new tab. Allowing the new tab will open a tab with a redirect link that never displays anything but a blank page.
Each time the user taps on the play icon again the pop-up number is increased by 1 -> the second time the user tries to open the video 2 new tabs are opened, the 3rd time 3 new tabs are opened and so on.

Also I have seen a difference between opening a direct link to the Facebook account and navigating to it. If the user goes to facebook.com the Desktop page is displayed and if he searches for the test account from here the video will be played. If the user opens the test account profile form a direct URL the Mobile version is displayed and in this version the videos experience the issues.

Since the stock browser opens the video in a video player maybe it's just a case of handling the redirect with an open in the VideoPlayer action similar to what happens with youtube videos.
(Reporter)

Updated

6 years ago
Keywords: qawanted, steps-wanted

Updated

6 years ago
status-firefox21: --- → affected
Using https://www.facebook.com/johnhammink find his public post Geometry_Animated. I don't get any popup notice. The content does not play. On the stock browser clicking on the video kicks you to the video playback app. Phone is a Galaxy Nexus running Android 4.2.

Updated

6 years ago
Whiteboard: [webcompat]
This might be a Facebook issue. It would be good to get the network requests we make when clicking the video.
Blocks: 759986
What I didn't capture in my video is that prior to playback, I accepted a popup. The reason there's a popup, is that in the code they are serving us, they have a target with '_blank' which invokes a popup:

<a class="touchable" href="/video_redirect/?src=http%3A%2F%2Fvideo.ak.fbcdn.net%2Fhvideo-ak-prn1%2Fv%2F755313_4816302378661_62866_n.mp4%3Foh%3D591169327dcd2c47064ff660ed470b5d%26oe%3D50F87797%26__gda__%3D1358462118_54ff028353a379161d42d9ae40491998&amp;refid=7&amp;_ft_=qid.5834514022054921834%3Amf_story_key.-7413640157292002654" target="_blank">
(Reporter)

Comment 9

6 years ago
This still does not work for me for the link and steps in Comment 0 on the HTC Desire Z (Android 2.3.3) on Nightly 21.0a1 2013-01-17. On the phone I don't get a doorhanger.
Did you clear site settings from a past opt-out?
(Reporter)

Comment 11

6 years ago
I am able to reproduce this issue on both the Samsung Galaxy R (Android 2.3.4) and Samsung Galaxy S2 (Android 4.0.3) with new installs of Nightly 21.0a1 2013-01-18. On the Galaxy S2 I am able to hear the video sound but no doorhangers, new tabs or video is displayed
(In reply to Kevin Brosnan [:kbrosnan] from comment #5)
> Using https://www.facebook.com/johnhammink find his public post
> Geometry_Animated. I don't get any popup notice. The content does not play.
> On the stock browser clicking on the video kicks you to the video playback
> app. Phone is a Galaxy Nexus running Android 4.2.

Does that mean you can reproduce? If so, can you show it to a developer?
Flags: needinfo?(kbrosnan)
Yes I can reproduce. I plan on being up in SF tomorrow will try to track down CPeterson or WesJ.
Flags: needinfo?(kbrosnan)
Did not catch either of them today.
Kevin - Feel free to show Sriram and/or Brian in MV.
Looked at this in the web inspector. This looks to be a Facebook bug with class="tlVideo accelerate" / data-sigil="m-timeline-video touchable orientation-resizable". The video content plays on touch but the poster element seems to stay at the top of the z-index stack. I can hear the audio playing and manually extracting the fbcdn-video-a.akamaihd.net mp4 URI plays back fine in Firefox.
Assignee: nobody → english-us
Status: REOPENED → NEW
tracking-fennec: ? → -
Component: General → English US
Product: Firefox for Android → Tech Evangelism
Does this bug also impact B2G?

cc Harald, who has been working with Facebook on technical issues.
Assignee: english-us → nobody
Component: English US → Mobile

Updated

5 years ago
Duplicate of this bug: 869286

Updated

5 years ago
status-firefox22: --- → affected
status-firefox23: --- → affected

Updated

5 years ago
Blocks: 869192

Updated

5 years ago
Summary: Shared videos directly on Facebook are not correctly supported → Shared videos directly on Facebook are not correctly supported (Android)

Updated

5 years ago
No longer blocks: 869192
Please do not flip around titles. The platform field is meant for determining whether the bug is platform dependent or not.
Summary: Shared videos directly on Facebook are not correctly supported (Android) → Shared videos directly on Facebook are not correctly supported
Also - please see comment 17. We haven't confirmed if it reproduces on b2g or not yet, so we don't know if this is platform dependent yet.
Blocks: 869192

Updated

5 years ago
Duplicate of this bug: 899845

Comment 22

5 years ago
Hi Andrew - Can someone on the Apps Review Team re test this on both Android and V1.1?
Assignee: nobody → awilliamson
Summary: Shared videos directly on Facebook are not correctly supported → Shared videos directly on Facebook are not correctly supported - ANDROID
Testing the video I shared on https://www.facebook.com/amo.editors

On Aurora on Android - tapping the video started video's audio but not the video, and I didn't see any popup.  

on 1.1 (unagi) - tapping the video correctly opened a popup and it played as expected.  (couldn't exit the thing though!  No back button, etc)

on 1.0.1 (unagi) - tapping the video did nothing.  

on 1.1 (zte open) - tapping the video did nothing.  The build was a (recent) ota update so its possible its lacking some patches I suppose.
Caused by the combination of this CSS:

.android .tlVideo .video, .ios .tlVideo .video{height:1px;left:50%;opacity:0;margin:39px 0 0;top:50%;width:1px}

and this JS:

if(o.webkitSupportsFullscreen)o.webkitEnterFullscreen();

meant to play the video in full screen (and assumes anything that is named "Android" supports webkitEnterFullscreen()).
So this needs to be fixed at Facebook. Known?
Assignee: awilliamson → nobody
Flags: needinfo?(browser-bugs)
Whiteboard: [webcompat] → [webcompat][serversniff]
Harald - Although this bug looks to be Android specific, given that you already have a working relationship with Facebook, can you please follow up?
Flags: needinfo?(hkirschner)
Whiteboard: [webcompat][serversniff] → [webcompat][serversniff][contactready]

Updated

5 years ago
Blocks: 916311

Updated

5 years ago
No longer blocks: 916311
Harald, ping?
We currently have a burning issue with blocking Firefox OS bug in FB. I will bring this up as soon as this is on the way from the FB side.
Flags: needinfo?(hkirschner)

Updated

5 years ago
Priority: -- → P1

Updated

5 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → affected
status-firefox27: --- → affected

Updated

5 years ago
Assignee: nobody → hkirschner
Severity: normal → major
Status: NEW → ASSIGNED

Comment 29

5 years ago
Taking a look.

Updated

5 years ago
Assignee: hkirschner → colby
Duplicate of this bug: 940891

Comment 31

5 years ago
Response from Colby@fb.com: I’m hoping to have a fix out for these next week, but that may be hindered by the holiday next week. I will keep you posted.
(Assignee)

Comment 32

5 years ago
As of this week, all Facebook videos should open in a new window/tab on Firefox clients.

That being said, Facebook serves all videos as MP4s which are not supported by older versions of Android (https://developer.mozilla.org/en-US/docs/HTML/Supported_media_formats#MP4_H.264_(AAC_or_MP3)).

Videos should now be viewable in all versions of Mobile Firefox which support MP4. Older versions will not be supported.

Comment 33

5 years ago
Adrian - Will you review comments/fix from FB and close the app if you no longer see the issue?
Flags: needinfo?(adriant.mozilla)
Adrian is no longer available; re-assigning
Flags: needinfo?(adriant.mozilla) → needinfo?(fennec)

Updated

5 years ago
Whiteboard: [webcompat][serversniff][contactready] → [webcompat][serversniff][sitewait] [country-all]

Comment 35

5 years ago
Using Galaxy R device with Android 2.3.4 the video is downloaded and open with the device's default app for videos. 
Using Galaxy Nexus with Android 4.2 I am able to see the video in a new tab. 

Video is mp4 - http://on.fb.me/19x1CJu (Same behavior with http://mzl.la/1j9eh8H)
Flags: needinfo?(fennec)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
Flags: needinfo?(browser-bugs)
You need to log in before you can comment on or make changes to this bug.