Closed Bug 825242 Opened 7 years ago Closed 7 years ago

Extremely slow loading web page when I leave the Library which chose 'new download view' opened once

Categories

(Firefox :: Bookmarks & History, defect, major)

20 Branch
x86
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 822343
Tracking Status
firefox20 - ---

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: perf, regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/f2a500997116
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121228 Firefox/20.0 ID:20121228030811

This does not happens if browser.library.useNewDownloadsView=false.


Steps to reproduce
1. Create new profile and copy sample places.sqlite attachment 695227 [details]
2. Start Firefox
3. Open Library and choose History or Bookmarks in the left pane. And stay open Library.
4. Open any web page in main window
   --- observe page loading speed

5. Choose Downloads in the left pane once, (and then choose History or Bookmarks optionally)
6. Open any web page in main window
   --- observe page loading speed

Actual results:
Extremely slow loading web page when I leave the Library which chose 'new download view' opened once.

ie. Step.4 normal speed
    Step.6 Extremely slow

Expected results:
 Loading of web page should be normal speed even if I leave the library which chose 'new download view' opened once
Depends on: 822343
Slow script warning appears:

>A script on this page may be busy, or it may have stopped responding. 
>You can stop the script now, or you can continue to see if the script will complete.
>
>Script: chrome://browser/content/downloads/allDownloadsViewOverlay.js:930
OS: Windows 7 → All
Just duping since there's no point in keeping this open
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 822343
No longer depends on: 822343
You need to log in before you can comment on or make changes to this bug.