Closed Bug 825422 Opened 9 years ago Closed 9 years ago

Intermittent Android robocop Shutdown | application crashed [@ mozalloc_abort(char const*)] after testMigration from java.lang.IllegalStateException: attempt to re-open an already-closed object: android.database.sqlite.SQLiteQuery

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Also misstarred as bug 821667 comment 5.

https://tbpl.mozilla.org/php/getParsedLog.php?id=18337764&tree=Mozilla-Inbound
Android no-ionmonkey Tegra 250 mozilla-inbound opt test robocop on 2012-12-29 06:47:25 PST for push 280420584744
slave: tegra-369

16 INFO TEST-END | testMigration | finished in 5512ms
17 INFO TEST-START | Shutdown
18 INFO Passed: 14
19 INFO Failed: 0
20 INFO Todo: 0
21 INFO SimpleTest FINISHED
INFO | automation.py | Application ran for: 0:00:10.161961
INFO | automation.py | Reading PID log: /tmp/tmpAbekNMpidlog
getting files in '/mnt/sdcard/tests/profile/minidumps/'
Downloading symbols from: http://ftp-scl3.mozilla.com/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-noion/1356788572/fennec-20.0a1.en-US.android-arm.crashreporter-symbols.zip
PROCESS-CRASH | Shutdown | application crashed [@ mozalloc_abort(char const*)]
Crash dump filename: /tmp/tmpdjrWG3/25f38b8b-723e-c6ab-6a1249e4-26aea50c.dmp
Operating system: Android
                  0.0.0 Linux 2.6.32.9-00002-gd8084dc-dirty #1 SMP PREEMPT Wed Feb 2 11:32:06 PST 2011 armv7l nvidia/harmony/harmony/harmony:2.2/FRF91/20110202.102810:eng/test-keys
CPU: arm
     0 CPUs

Crash reason:  SIGSEGV
Crash address: 0x0

Thread 0 (crashed)
 0  libmozalloc.so!mozalloc_abort(char const*) [mozalloc_abort.cpp : 23 + 0x4]
     r4 = 0xafd42550    r5 = 0xbe96b72c    r6 = 0x485653a0    r7 = 0x430cbf34
     r8 = 0xbe96b7b0    r9 = 0x430cbf2c   r10 = 0x430cbf18    fp = 0x00000000
     sp = 0xbe96b728    lr = 0xafd162f5    pc = 0x44965750
    Found by: given as instruction pointer in context
 1  libc.so + 0x162f3
     r4 = 0xafd42550    r5 = 0xbe96b72c    r6 = 0x485653a0    r7 = 0x430cbf34
     r8 = 0xbe96b7b0    r9 = 0x430cbf2c   r10 = 0x430cbf18    fp = 0x00000000
     sp = 0xbe96b728    pc = 0xafd162f5
    Found by: call frame info
 2  libc.so + 0x436fe
     sp = 0xbe96b744    pc = 0xafd43700
    Found by: stack scanning
 3  libc.so + 0x4378e
     sp = 0xbe96b748    pc = 0xafd43790
    Found by: stack scanning
 4  libc.so + 0x4372a
     sp = 0xbe96b74c    pc = 0xafd4372c
    Found by: stack scanning
 5  libdvm.so + 0x16ffe
     sp = 0xbe96b75c    pc = 0x80817000
    Found by: stack scanning
 6  libc.so + 0xbe61
     sp = 0xbe96b768    pc = 0xafd0be63
    Found by: stack scanning
 7  2 (deleted) + 0x16
     sp = 0xbe96b770    pc = 0x484fd018
    Found by: stack scanning
 8  libc.so + 0x4372a
     sp = 0xbe96b774    pc = 0xafd4372c
    Found by: stack scanning
 9  libmozglue.so!Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash [APKOpen.cpp : 319 + 0x5]
     sp = 0xbe96b7a8    pc = 0x80c1145f
    Found by: stack scanning
10  libdvm.so + 0x16e36
     r4 = 0xbe96b7d0    sp = 0xbe96b7b0    pc = 0x80816e38
    Found by: call frame info
11  dalvik-LinearAlloc (deleted) + 0x221506
     sp = 0xbe96b7b8    pc = 0x432ed508
...
15:21:19.513 I/Robocop ( 4370): 21 INFO SimpleTest FINISHED
12-27 15:21:19.713 W/InputManagerService( 1020): Starting input on non-focused client com.android.internal.view.IInputMethodClient$Stub$Proxy@48443340 (uid=10033 pid=4370)
12-27 15:21:19.793 I/GeckoAboutHome( 4370): filestream is null
12-27 15:21:19.823 D/AndroidRuntime( 4370): Shutting down VM
12-27 15:21:19.903 E/GeckoAppShell( 4370): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
12-27 15:21:19.903 E/GeckoAppShell( 4370): java.lang.IllegalStateException: attempt to re-open an already-closed object: android.database.sqlite.SQLiteQuery (mSql = SELECT _id, url, title FROM combined WHERE ((url NOT LIKE ?)) GROUP BY url ORDER BY (CASE WHEN bookmark_id > -1 THEN 100 ELSE 0 END) + visits * MAX(1, 100 * 225 / ((date - 1356621665950) / 86400000*(date - 1356621665950) / 86400000 + 225))  DESC LIMIT 6) 
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.database.sqlite.SQLiteClosable.acquireReference(SQLiteClosable.java:34)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.database.sqlite.SQLiteQuery.fillWindow(SQLiteQuery.java:64)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.database.sqlite.SQLiteCursor.fillWindow(SQLiteCursor.java:283)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.database.sqlite.SQLiteCursor.onMove(SQLiteCursor.java:255)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.database.AbstractCursor.moveToPosition(AbstractCursor.java:188)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.database.CursorWrapper.moveToPosition(CursorWrapper.java:187)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.database.CursorWrapper.moveToPosition(CursorWrapper.java:187)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.widget.CursorAdapter.getItemId(CursorAdapter.java:155)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.widget.AdapterView.getItemIdAtPosition(AdapterView.java:745)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.widget.AdapterView.setSelectedPositionInt(AdapterView.java:1081)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.widget.GridView.setAdapter(GridView.java:143)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at org.mozilla.gecko.AboutHomeContent$7.run(AboutHomeContent.java:272)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.os.Handler.handleCallback(Handler.java:587)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.os.Handler.dispatchMessage(Handler.java:92)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.os.Looper.loop(Looper.java:123)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at java.lang.reflect.Method.invokeNative(Native Method)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at java.lang.reflect.Method.invoke(Method.java:521)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
12-27 15:21:19.903 E/GeckoAppShell( 4370): 	at dalvik.system.NativeStart.main(Native Method)
12-27 15:21:20.423 W/WindowManager( 1020): Permission denied: injecting key event from pid 4370 uid 10033 to window Window{4851e860 com.mozilla.SUTAgentAndroid/com.mozilla.SUTAgentAndroid.SUTAgentAndroid paused=false} owned by uid 10031
12-27 15:21:21.383 I/TestRunner( 4370): finished: testMigration(org.mozilla.fennec.tests.testMigration)
12-27
https://tbpl.mozilla.org/php/getParsedLog.php?id=18337764&tree=Mozilla-Inbound shows:

12-29 07:04:37.793 E/GeckoAppShell( 3663): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
12-29 07:04:37.793 E/GeckoAppShell( 3663): java.lang.RuntimeException: Unable to destroy activity {org.mozilla.fennec/org.mozilla.fennec.App}: java.lang.NullPointerException
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3655)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at android.app.ActivityThread.handleDestroyActivity(ActivityThread.java:3673)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at android.app.ActivityThread.access$2900(ActivityThread.java:125)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2066)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at android.os.Handler.dispatchMessage(Handler.java:99)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at android.os.Looper.loop(Looper.java:123)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at java.lang.reflect.Method.invokeNative(Native Method)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at java.lang.reflect.Method.invoke(Method.java:521)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at dalvik.system.NativeStart.main(Native Method)
12-29 07:04:37.793 E/GeckoAppShell( 3663): Caused by: java.lang.NullPointerException
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at org.mozilla.gecko.AboutHomeContent.onDestroy(AboutHomeContent.java:245)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at org.mozilla.gecko.BrowserApp.onDestroy(BrowserApp.java:236)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3642)
12-29 07:04:37.793 E/GeckoAppShell( 3663): 	... 11 more
Regression from bug 783312 (you can see this happening in the try run at https://tbpl.mozilla.org/?tree=Try&rev=eb09bf4733c7).
Blocks: 783312
This hasn't occurred since -> calling WFM for now.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.