Last Comment Bug 825434 - Updating widget.contentURL breaks communication between content script and main
: Updating widget.contentURL breaks communication between content script and main
Status: RESOLVED DUPLICATE of bug 748677
:
Product: Add-on SDK
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: P3 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 826406
  Show dependency treegraph
 
Reported: 2012-12-29 09:10 PST by Marc Chevrier
Modified: 2013-04-04 18:32 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
bug-widget.zip (1.12 KB, application/octet-stream)
2012-12-29 09:10 PST, Marc Chevrier
no flags Details

Description Marc Chevrier 2012-12-29 09:10:50 PST
Created attachment 696513 [details]
bug-widget.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Create a widget with a script attached which post a message on event 'click'.
After widget creation, change contentURL by assigning widget property.


Actual results:

messages emitted from the content script are no longer received in the main script.


Expected results:

Changing the contentURL property of the widget should not have impact on communication and main script should continue to receive messages posted in the content script.
Comment 1 Marc Chevrier 2012-12-29 09:16:47 PST
the two files attached could be used to create a simple add-on showing the problem.
At add-on installation, right or left clicking on the widget icon will result in a message in the console.
After 6 seconds, the contentURL property of the widget is changed (using setTimeout). After this change, clicking on the widget icon does not show a message in the console.
Comment 2 Erik Vold [:erikvold] (please needinfo? me) 2013-04-04 18:32:28 PDT

*** This bug has been marked as a duplicate of bug 748677 ***

Note You need to log in before you can comment on or make changes to this bug.