There should be a progress bar on the downloading icon in the dock on OS X.

REOPENED
Unassigned

Status

()

Firefox
General
--
enhancement
REOPENED
5 years ago
5 years ago

People

(Reporter: jsbruner, Unassigned)

Tracking

({uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 696651 [details]
Safari download Icon.

On every version of Firefox, even without the new download panel, files are downloaded. However, they are always downloaded without any feedback inside the OS itself. That is, compared to Safari or Chrome, there isn't any blue bar that shows progress for the downloading file.

This causes issues. If you do not notice a file is downloading, you might open up the file, which causes problems, as the data is not finished. Really, the downloading files need to act as they do on Safari, with a blue progress bar, and can not be clicked on while downloading.

Updated

5 years ago
No longer blocks: 636455
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548763
Marking as not a duplicate. This bug is about adding a progress bar to the downloading icon, not the firefox icon. The referenced bug does not implement this ability.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

5 years ago
Josiah, to clarify: By "the downloading icon", you mean the icon of the folder into which the file is being downloaded?
(In reply to Dave Vasilevsky from comment #3)
> Josiah, to clarify: By "the downloading icon", you mean the icon of the
> folder into which the file is being downloaded?

Correct. If you have the Downloads stack icon on your dock, then we should draw the progress bar there as well.
You need to log in before you can comment on or make changes to this bug.