Closed Bug 825549 Opened 9 years ago Closed 5 months ago

Mention all changesets (also for the 3 "small" repositories) in seamonkey-*.txt

Categories

(SeaMonkey :: Build Config, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 630514

People

(Reporter: tonymec, Unassigned)

Details

Each nightly, hourly, etc. build comes as a number of files. The big one is of course the archive (.installer.exe and .zip for Windows, .tar.bz2 for Linux, .dmg for Mac) but there is also a small .txt file saying "what the build is about".

The latest (hourly) seamonkey-2.17a1.en-US.linux-x86_64.txt is as follows:

20121230025328
http://hg.mozilla.org/mozilla-central/rev/eb2f5c66561b
http://hg.mozilla.org/comm-central/rev/17d78086de57

The first line is the build ID, the other two are the changesets from the two "big" repositories. ATM there is no easy way to know exactly which changeset was pulled from the 4 "small" repositories (ChatZilla, DOMi, LDAP and Venkman) especially since the build ID is known to err sometimes by a few hours, and has recently been 9 days off on Linux64.

I propose to add the changeset IDs from the 4 "small" repositories, as found in the output of "client.py checkout". (Lines starting "pulling from " give the repository URL, lines starting "Updated to revision " give the full 40-nybble CSID, I suppose a 12-nybble ID would be sufficient.)
Duplicate of bug 630514?
Editing the title to reflect the fact that Venkman has been dropped (some time ago already).
Summary: Mention all changesets (also for the 4 "small" repositories) in seamonkey-*.txt → Mention all changesets (also for the 3 "small" repositories) in seamonkey-*.txt
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630514
You need to log in before you can comment on or make changes to this bug.