Closed Bug 825612 Opened 8 years ago Closed 7 years ago

Autophone - s1s2 - Regression in "time to throbber start" and "time to throbber stop" - Dec 22

Categories

(Firefox for Android :: General, defect)

x86
Android
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
fennec + ---

People

(Reporter: gbrown, Assigned: sriram)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

http://mrcote.info/phonedash/#/org.mozilla.fennec/throbberstart/local-twitter/2012-12-01/2012-12-31 shows a small (< 200 ms) increase in the time to throbber start, for most phones, on Dec 22.

For example, 20_64_32_4f_e9_4f_samsung_gs2_4.03 has a time of 855 at https://hg.mozilla.org/mozilla-central/rev/04abdd43606b and a time of 906 at https://hg.mozilla.org/mozilla-central/rev/ea373e534245.


http://mrcote.info/phonedash/#/org.mozilla.fennec/throbberstop/local-twitter/2012-12-01/2012-12-31 shows a small (< 200 ms) increase in the time to throbber stop, for most phones, on Dec 22.

For example, 78_d6_f0_cf_8d_11_nexus_s has a time of 4969 at https://hg.mozilla.org/mozilla-central/rev/04abdd43606b and a time of 5234 at https://hg.mozilla.org/mozilla-central/rev/84320dffec6e.
tracking-fennec: --- → ?
There is also a significant regression in the eideticker startup test at about the same time: http://eideticker.wrla.ch/#/samsung-gn/startup-abouthome-cold/timetostableframe
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=04abdd43606b&tochange=ea373e534245

throbber start and throbber stop are reported on logcat so this regression range can be narrowed manually. You could even write a script to work with hg bisect.
Assignee: nobody → bnicholson
tracking-fennec: ? → 20+
See Also: → 830416
I'm able to reproduce this regression on my Galaxy S, so I created a bisect script. Output attached.

Looks like the regression is from https://hg.mozilla.org/mozilla-central/rev/296cc3ea6e9e.
Attachment #702403 - Attachment mime type: text/x-log → text/plain
Assigning to Sriram since he was looking at a fix.
Assignee: bnicholson → sriram
I removed the code that dealt with Tabs. Did the regression change back to the better side?
No longer an issue with bug 817706 gone.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Actually, there still appears to be a regression; see http://mrcote.info/phonedash/#/org.mozilla.fennec/throbberstop/local-twitter/2012-11-26/2013-01-25
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
tracking-fennec: 20+ → +
(In reply to Geoff Brown [:gbrown] from comment #0)
> http://mrcote.info/phonedash/#/org.mozilla.fennec/throbberstart/local-
> twitter/2012-12-01/2012-12-31 shows a small (< 200 ms) increase in the time
> to throbber start, for most phones, on Dec 22.
> 

http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstart/local-twitter/2012-12-01/2012-12-31/notcached/noerrorbars/standarderror

> For example, 20_64_32_4f_e9_4f_samsung_gs2_4.03 has a time of 855 at
> https://hg.mozilla.org/mozilla-central/rev/04abdd43606b and a time of 906 at
> https://hg.mozilla.org/mozilla-central/rev/ea373e534245.
> 
> 
> http://mrcote.info/phonedash/#/org.mozilla.fennec/throbberstop/local-twitter/
> 2012-12-01/2012-12-31 shows a small (< 200 ms) increase in the time to
> throbber stop, for most phones, on Dec 22.
> 

http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-twitter/2012-12-01/2012-12-31/notcached/noerrorbars/standarderror

> For example, 78_d6_f0_cf_8d_11_nexus_s has a time of 4969 at
> https://hg.mozilla.org/mozilla-central/rev/04abdd43606b and a time of 5234
> at https://hg.mozilla.org/mozilla-central/rev/84320dffec6e.

(In reply to Brian Nicholson (:bnicholson) from comment #7)
> Actually, there still appears to be a regression; see
> http://mrcote.info/phonedash/#/org.mozilla.fennec/throbberstop/local-twitter/
> 2012-11-26/2013-01-25

http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-twitter/2012-11-26/2013-01-25/notcached/noerrorbars/standarderror
Sorry I didn't look into this when we had builds available. There are more recent issues I think we can focus on where I can determine tight regression ranges, so I'm going to mark this as incomplete. :-(
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → INCOMPLETE
Summary: Regression in "time to throbber start" and "time to throbber stop" - Dec 22 → Autophone - s1s2 - Regression in "time to throbber start" and "time to throbber stop" - Dec 22
You need to log in before you can comment on or make changes to this bug.