Closed Bug 825635 Opened 7 years ago Closed 7 years ago

Volume control stops working in FM when headset is unplugged and plugged

Categories

(Firefox OS Graveyard :: General, defect, P3)

x86
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

RESOLVED FIXED
B2G C4 (2jan on)
blocking-basecamp +
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: jhopkins, Assigned: rlin)

References

Details

(Keywords: b2g-testdriver, unagi, Whiteboard: testrun 3)

Attachments

(1 file, 1 obsolete file)

The volume control stops working after following these steps:

1) Boot up the phone
2) Start the FM radio
3) Plug in a headset
4) Listen to the radio for a moment and adjust volume (note: volume actually changes)
5) Unplug the headset
6) Plug the headset back in
7) Adjust the volume and note that it does not result in a volume change any longer.
Assignee: nobody → alive
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)
I think this is more like a platform bug. Redirect to Randy.

It seems when FM is changing its state, the audio-channel-changed is not fired at step(7).
Assignee: alive → rlin
Summary: Volume control stops working → Volume control stops working in FM when headset is unplugged and plugged
Component: Gaia::FMRadio → General
Attached patch fix-patch1 (obsolete) — Splinter Review
If FM radio turn off, the mCurrentHigherChannel would keep in AUDIO_CHANNEL_CONTENT,so if the next FM radio turning on, the getMuted function wouldn't broadcast audio channel change, cause by this statement:higher == mCurrentHigherChannel == AUDIO_CHANNEL_CONTENT.

Music isn't has this problem. I found the getMuted would check normal channel first and that would replace mCurrentHigherChannel value. then check CONTENT channel again.
Attachment #697340 - Flags: review?(amarchesini)
Duplicate of this bug: 825816
Attachment #697340 - Flags: review?(amarchesini) → review+
Attached patch checkin-patchSplinter Review
check in patch
Attachment #697340 - Attachment is obsolete: true
Attachment #697365 - Attachment is patch: true
https://hg.mozilla.org/mozilla-central/rev/4dbb2c7bc4d0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
This patch needs to phase in b2g-18 trunk.
Duplicate of this bug: 826770
In Unagi build 20130125070201 Version 18.0 This bug is still occurring. If I turn the radio on then press the power button to make the screen dark, The Hardware volume buttons are not reliable. I was able to turn the volume down but could not turn the volume back up.

I've already written a bug about it but it was duped and I know people hate reopening bugs. So I'll just comment and leave it up to the powers that be.

I'm running Testrun 3 and it fails testcase https://moztrap.mozilla.org/runtests/run/702/env/296/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=3933&filter-suite=168

Build ID: 20130125070201
Kernel: Dec 5
Additional info
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18/rev/94a2d6fcdfde
Gaia:   6369dbf33b622faf4b4d176fed30b77c5c319dfc
Whiteboard: testrun 3
You need to log in before you can comment on or make changes to this bug.