Last Comment Bug 825734 - Plugins stop rendering when the top half of the plugin is scrolled off the top of the page, in HiDPI mode
: Plugins stop rendering when the top half of the plugin is scrolled off the to...
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Mac OS X
: P1 normal with 1 vote (vote)
: mozilla20
Assigned To: Steven Michaud [:smichaud] (Retired)
: Matt Wobensmith [:mwobensmith][:matt:]
:
Mentors:
Depends on:
Blocks: 674373
  Show dependency treegraph
 
Reported: 2013-01-01 00:38 PST by Chris Peterson [:cpeterson]
Modified: 2013-02-21 11:35 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
+
wontfix
+
verified
+
verified
19+


Attachments
Fix (1.41 KB, patch)
2013-01-04 09:18 PST, Steven Michaud [:smichaud] (Retired)
jfkthame: review+
bajaj.bhavana: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Chris Peterson [:cpeterson] 2013-01-01 00:38:32 PST
STR:
1. Play any Flash video on YouTube or Vimeo
2. While the video is playing, slowly scroll down the page so the video is half off the top of the page

RESULT:
The video stops rendering, but the audio continues playing. If you scroll up the page so more of the video is visible, the video will begin rendering again.

I believe this is a regression from HiDPI bug 674373. I'm using a Retina MacBook Pro.

I bisected Nightly builds and identified Nightly 18 build 2012-09-30 as the regression point. Here is the changelog from build 09-29 to 09-30:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c09a0c022b2e&tochange=a680fd777c3b
Comment 1 bhavana bajaj [:bajaj] 2013-01-02 10:39:00 PST
(In reply to Chris Peterson (:cpeterson) from comment #0)
> STR:
> 1. Play any Flash video on YouTube or Vimeo
> 2. While the video is playing, slowly scroll down the page so the video is
> half off the top of the page
> 
> RESULT:
> The video stops rendering, but the audio continues playing. If you scroll up
> the page so more of the video is visible, the video will begin rendering
> again.
> 
> I believe this is a regression from HiDPI bug 674373. I'm using a Retina
> MacBook Pro.
> 
> I bisected Nightly builds and identified Nightly 18 build 2012-09-30 as the
> regression point. Here is the changelog from build 09-29 to 09-30:
> 
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=c09a0c022b2e&tochange=a680fd777c3b

Hey Chris, I have tried with on FF18.0b7 with flash version 11.5.502.136 Mac OSX 10.8.2 on retina display and unable to reproduce it.Can you please comment on a)are you able to reproduce this consistently for any specific url's b)What version's of FF,flash are you on c)any other specific details on plugin's or env you may have to help reproduce.

In addition CC-ing qa here to see if they can help.Marcia, can you please help & try to reproduce this on your machine ?
Comment 2 Chris Peterson [:cpeterson] 2013-01-02 11:04:05 PST
(In reply to bhavana bajaj [:bajaj] from comment #1)
> Hey Chris, I have tried with on FF18.0b7 with flash version 11.5.502.136 Mac
> OSX 10.8.2 on retina display and unable to reproduce it.Can you please
> comment on a)are you able to reproduce this consistently for any specific
> url's b)What version's of FF,flash are you on c)any other specific details
> on plugin's or env you may have to help reproduce.

I was using Flash 11.6.602.108 (Beta) on my Retina MacBook Pro.

I am NOT able to reproduce this bug on my non-Retina MacBook Pro (with FF20 and Flash 11.6.602.108 Beta). I can retest my Retina MacBook Pro with a non-beta version of Flash tonight.
Comment 3 Marcia Knous [:marcia - use ni] 2013-01-02 11:18:52 PST
Chris: I just tried to repro using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130102 Firefox/20.0. I have the same Beta Flash version as you do, and I cannot get it to reproduce playing the staff picks at http://vimeo.com/. Is it possible you have an addon that may be contributing to this issue?

I am using 10.8.3, Build 12D44 which is probably ahead of what you have.
Comment 4 Steven Michaud [:smichaud] (Retired) 2013-01-02 13:16:19 PST
I can repro in FF 18.0b7 and today's mozilla-central nightly with the following example:

http://mirrors.creativecommons.org/getcreative/

You need reduce the page height quite a bit to make it scrollable enough for the bug to happen.

I tested on OS X 10.7.5.  Just a sec and I'll test on 10.8.2.

(I'm testing on a Retina MBP.)
Comment 5 Steven Michaud [:smichaud] (Retired) 2013-01-02 13:31:45 PST
I can also repro on OS X 10.8.2.

The bug doesn't happen with HiDPI mode disabled (with gfx.hidpi.enabled set to '-1').

I'll be working on this.
Comment 6 Steven Michaud [:smichaud] (Retired) 2013-01-02 13:32:58 PST
Anyone know of a Silverlight animation (or one that uses some other plugin than Flash)?
Comment 7 Chris Peterson [:cpeterson] 2013-01-02 14:28:56 PST
Here is a Silverlight video:

https://www.microsoft.com/silverlight/skinning-and-styling/
Comment 8 Steven Michaud [:smichaud] (Retired) 2013-01-02 14:34:43 PST
Thanks, Chris.

I can also reproduce this bug with it.  Can you?
Comment 9 Chris Peterson [:cpeterson] 2013-01-02 20:26:03 PST
(In reply to Steven Michaud from comment #8)
> I can also reproduce this bug with it.  Can you?

Yes. On my Retina MacBook Pro, I can reduce the bug when playing the Silverlight video. I have Silverlight 5.1.10411.0.
Comment 10 bhavana bajaj [:bajaj] 2013-01-02 22:07:46 PST
(In reply to Steven Michaud from comment #4)
> I can repro in FF 18.0b7 and today's mozilla-central nightly with the
> following example:
> 
> http://mirrors.creativecommons.org/getcreative/
> 
> You need reduce the page height quite a bit to make it scrollable enough for
> the bug to happen.

Was able to reproduce the issue with the above suggestion. Steven, could you please help with ETA on the patch ?
> 
> I tested on OS X 10.7.5.  Just a sec and I'll test on 10.8.2.
> 
> (I'm testing on a Retina MBP.)
Comment 11 Steven Michaud [:smichaud] (Retired) 2013-01-03 07:16:54 PST
> Steven, could you please help with ETA on the patch?

My guess is 2-3 days.

It's definitely our bug (since it effects both Flash and Silverlight).  So the fix (when found) will probably be straightforward, and therefore low risk.  But first I have to find it.

I'll be spending most of my time on this bug until I have.
Comment 12 bhavana bajaj [:bajaj] 2013-01-03 10:48:02 PST
We will wontfix this issue within FF18 timeframe given the aligned release timelines,amount of testing this patch will get & to avoid any surprise worse regression this may cause in case we decide to uplift in our release candidate.

Although,we will uplift the patch to FF19 once ready.
Comment 13 Benjamin Smedberg [:bsmedberg] 2013-01-03 10:55:18 PST
Bhavana, in that case this should probably be added to the FF18 relnotes.
Comment 14 Steven Michaud [:smichaud] (Retired) 2013-01-03 16:21:08 PST
I've got this fixed, I think.

I'll post the patch tomorrow, after I've had a chance to do some more testing.
Comment 15 Steven Michaud [:smichaud] (Retired) 2013-01-04 09:18:39 PST
Created attachment 697953 [details] [diff] [review]
Fix

Here's my patch, which as I expected is simple and low-risk.

Turns out we overlooked that mClipRects uses device pixels.

I've tested this on OS X 10.7.5 and 10.8.2, with both testcases from this bug.  I didn't see any problems.
Comment 16 Steven Michaud [:smichaud] (Retired) 2013-01-04 09:41:36 PST
Here's a tryserver build made using my patch from comment #15:
http://ftp-scl3.mozilla.com/pub/mozilla.org/firefox/try-builds/smichaud@pobox.com-76e52bf8839b/try-macosx64/firefox-20.0a1.en-US.mac.dmg
Comment 17 Jonathan Kew (:jfkthame) 2013-01-04 14:20:54 PST
Comment on attachment 697953 [details] [diff] [review]
Fix

Review of attachment 697953 [details] [diff] [review]:
-----------------------------------------------------------------

Looks OK to me, but while you're here, maybe it'd be good to add a comment to the declaration of GetPluginClipRect to remind us that the (output) parameters it returns are Cocoa points (AKA display pixels), not device pixels (which is usually what nsIntRect/nsIntPoint values are used for).
Comment 18 Steven Michaud [:smichaud] (Retired) 2013-01-04 14:43:08 PST
Comment on attachment 697953 [details] [diff] [review]
Fix

Landed on mozilla-inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/850b01396805

I added comments to both the declaration and the definition.
Comment 19 Phil Ringnalda (:philor) 2013-01-05 16:28:34 PST
https://hg.mozilla.org/mozilla-central/rev/850b01396805
Comment 20 Chris Peterson [:cpeterson] 2013-01-07 10:33:55 PST
Verified fixed in Nightly 20.0a1 (2013-01-07)
Comment 21 bhavana bajaj [:bajaj] 2013-01-07 11:17:57 PST
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #13)
> Bhavana, in that case this should probably be added to the FF18 relnotes.

Benjamin,this has been taken care off for FF18.0 release notes :)
Comment 22 bhavana bajaj [:bajaj] 2013-01-09 16:59:27 PST
Steven, can you please nominate the patch for beta approval as 19's affected?
Comment 23 Steven Michaud [:smichaud] (Retired) 2013-01-09 17:39:28 PST
Comment on attachment 697953 [details] [diff] [review]
Fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 674373 (which added support for HiDPI displays)
User impact if declined: Plugin rendering broken in HiDPI mode in many common use cases
Testing completed (on m-c, etc.): Some testing by myself, plus several days testing on m-c
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Comment 24 bhavana bajaj [:bajaj] 2013-01-09 21:40:00 PST
Adding qawanted,verify me to get QA help to verify this bug with a couple of plugins in HiDPi and non-HiDPI as the patch touches general widgets code .. Thanks !
Comment 25 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-10 10:42:13 PST
(In reply to bhavana bajaj [:bajaj] from comment #24)
> Adding qawanted,verify me to get QA help to verify this bug with a couple of
> plugins in HiDPi and non-HiDPI as the patch touches general widgets code ..
> Thanks !

Marcia's currently busy with B2G work and I don't have a Retina Mac. I've asked Matt Wobensmith to help out here.
Comment 26 Matt Wobensmith [:mwobensmith][:matt:] 2013-01-10 11:35:30 PST
Confirmed issue on nightly, 2013-01-01
Confirmed fixed on nightly, 2013-10-10

With an affected build, I can see the behavior by default, and then "fix" it by setting the value of gfx.hidpi.enabled from 2 to -1. On the latest build, both values allow content to display correctly.

This is using a Retina MacBook Pro, 10.8.2. 

I used both Flash and Silverlight examples included above.
Comment 27 Steven Michaud [:smichaud] (Retired) 2013-01-11 14:42:22 PST
Comment on attachment 697953 [details] [diff] [review]
Fix

Landed on mozilla-beta:
https://hg.mozilla.org/releases/mozilla-beta/rev/57559b63f115
Comment 28 Matt Wobensmith [:mwobensmith][:matt:] 2013-01-15 11:19:50 PST
Confirmed fixed 2013-01-15, beta
Comment 29 Ryan 2013-02-18 21:09:38 PST
This also needs removing from the list of known issues on the release notes.

Note You need to log in before you can comment on or make changes to this bug.