Closed Bug 825776 Opened 8 years ago Closed 8 years ago

Firefox on Windows has focus issues when using multiple windows

Categories

(Firefox :: Untriaged, defect)

17 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 768802

People

(Reporter: radx4, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Starting a few months ago something changed in Firefox that causes focus issues when browsing in multiple windows simultaneously.  Specifically, when a link is opened in a new window Firefox will sometimes switch focus back to the original window.  I have observed this bug on at least Windows 7 and Windows XP.  I hoped the bug would have been fixed by now, but it's possible that it went unnoticed since most people use tabs instead of separate windows.

Here's a specific procedure for reproducing the bug:
1.  Go to http://www.google.com
2.  Click File -> New Window (or Ctrl+N) to open a new window
3.  Go to http://www.google.com in the new window and enter a search
4.  Right click on any search result and select "Open in new window"


Actual results:

In the above example, Firefox will open the link in a new window but then immediately switch focus back to the search results window.


Expected results:

The new window should have maintained focus.  This is actually the default behavior of the operating system, so Firefox must be doing something that results in the improper focus change.
Let me guess: It works if you disable the flash plugin in tools/addons/plugins and it happens only if the flash plugin is started.
The flash plugin is started directly after a Firefox start when the first page with a flash applet is opened. It will be only stopped after some time (2min ?) when no page is using it.

Is that correct ?
Yes, after testing without flash the problem does not occur.  Hmm, I'm probably going to have a hard time getting anything from Adobe, but it's worth a shot.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 768802
I forgot to add: try to disable the protected mode as explained in bug 768802
You need to log in before you can comment on or make changes to this bug.