Closed Bug 825809 Opened 8 years ago Closed 8 years ago

mWaitingForContentToPaint should be true after mPaintThrottler.TaskComplete post new task

Categories

(Core :: Graphics, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox19 --- wontfix
firefox20 --- fixed
b2g18 + fixed
b2g18-v1.0.0 --- affected

People

(Reporter: romaxa, Assigned: romaxa)

References

Details

Attachments

(1 file)

I've found one problem with mWaitingForContentToPaint and 
http://mxr.mozilla.org/mozilla-central/source/gfx/layers/ipc/AsyncPanZoomController.cpp#1156

Basically we have case when RequestContentRepaint posted but not tracked by mWaitingForContentToPaint.
this happen when we call mPaintThrottler.TaskComplete which Run queued task, and do not set mWaitingForContentToPaint = true in that case.
Assignee: nobody → romaxa
Status: NEW → ASSIGNED
Attachment #696928 - Flags: review?(jones.chris.g)
Btw, this patch fixes content shaking during scroll with FLING
Attachment #696928 - Flags: review?(jones.chris.g) → review?(ajones)
Attachment #696928 - Flags: review?(ajones) → review+
Is this a patch we should track for uplifting to b2g18?
tracking-b2g18: --- → ?
https://hg.mozilla.org/mozilla-central/rev/97d2ac9d16c4
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
We'll track, please nominate for approval with reasons for uplift and risk assessment.
Comment on attachment 696928 [details] [diff] [review]
Track waiting for task executed in TaskComplete

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 799401
User impact if declined: Unpainted (white) regions on screen.
Testing completed: Has been on m-c for some time.
Risk to taking this patch (and alternatives if risky): Low. The bug was a clear oversight that missed an edge case.
String or UUID changes made by this patch: None.
Attachment #696928 - Flags: approval-mozilla-b2g18?
Attachment #696928 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
You need to log in before you can comment on or make changes to this bug.