[GALLERY] Graphical issues when rotating photos in full screen

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Gallery
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: carlosmartinez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Tested in unagi with:

Gecko-49bd828 
Gaia-bf20d71

STR:
1-Open gallery app
2-Open a photo fullscreen
3-Rotate the device in order to rotate the photo

Expected result --> Photo is rotated without any graphical issue
Actual result --> Photo is rotated but a white rectangle is shown everytime you rotate it
Dupe of bug 805939?
(In reply to Andrew Overholt [:overholt] from comment #1)
> Dupe of bug 805939?

Same thing that the one described in the bug, but during more time. BTW changes for this bug are already landed but the problem seems to be still there.
The flash of white we see is white because of this code in apps/system/style/system/system.css:

#windows > iframe.appWindow:not(.homescreen) {
  background-color: #fff;
}

If I change that to red, I'll see red when I change orientation. But that also changes the default background color of other apps, so we can't fix it that way.

This bug is related to 823327, which flashes the same color when entering fullscreen mode.

Updated

5 years ago
Blocks: 805939
This is different from bug 823327 apparently.

I don't see a flash of white. For me, switching from portrait to landscape works fine, while switching from landscape to portrait produces a glitch, but it's not a flash of white.
Tested and switching from portrait to landscape and back works fine in below environment. Please reopen the bug if anyone still sees the issue

Device Hamachi
OS Version 1.4.0.0-prerelease
Platform 29.0a1
BuildId:20140123040608
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.