If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CSS text-shadow on ::-moz-selection not applied when losing focus

RESOLVED DUPLICATE of bug 706209

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 706209
5 years ago
5 years ago

People

(Reporter: Cacycle, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 697136 [details]
Testcase selection text-shadow

After the fixes of bug 721750, the text-shadow property is now correctly applied to selections in Firefox 17.0.1 (Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0).

However, as soon as the selection containing object becomes unfocused (i.e. a blue selection turns grey), the text-shadow property no longer applied to the selection.

This behavior feels wrong and has probably been missed in the patches (unless I miss some sophisticated CSS magic here). 

To replicate, open the first testcase, select some text (the shadow disappears). Then click into the address bar to remove the focus (shadow re-appears in the unfocused selection).
(Reporter)

Updated

5 years ago
Depends on: 721750
(Reporter)

Updated

5 years ago
Attachment #697136 - Attachment mime type: text/plain → text/html
Component: General → Style System (CSS)
Product: Firefox → Core
Keywords: testcase

Updated

5 years ago
Blocks: 721750
No longer depends on: 721750
Keywords: regression
Version: unspecified → Trunk
Why is this marked "regression"?

Before bug 721750 this didn't work at all.

Now it works for ::-moz-selection (fixed in bug 721750), but unfocused selections don't actually match ::-moz-selection (see bug 706209), so no ::-moz-selection styles are ever applied to them (you can see the same thing with color, background, etc, not just text-shadow).
No longer blocks: 721750
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 706209
You need to log in before you can comment on or make changes to this bug.