Closed Bug 826159 Opened 7 years ago Closed 7 years ago

Cookie Manager doesn't display non-ASCII cookie values correctly

Categories

(Core :: Networking: Cookies, defect)

x86_64
Windows 8
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: emk, Assigned: emk)

References

()

Details

Attachments

(1 file, 1 obsolete file)

Steps to reproduce:
1. Open the URL.
2. View the Cookie value from Options > Privacy > remove individual cookies.
3. Open the Web Console and type and type |document.cookie|.
4. Compare both values.

Actual result:
The former value contains 'utmccn=Some%20Name%20–%202013' while the latter contains 'utmccn=Some%20Name%20–%202013'.

Expected result:
Both values should be the same (have 'utmccn=Some%20Name%20–%202013').
Actually this was a Core issue.
https://mxr.mozilla.org/mozilla-central/source/netwerk/cookie/nsICookie.idl?rev=a16372ce30b5&mark=29-29#19
>    readonly attribute ACString value;
should be
     readonly attribute AUTF8String value;
.
Component: Preferences → Networking: Cookies
Product: Firefox → Core
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Attachment #697387 - Flags: review?(bzbarsky)
Attached patch patch v2Splinter Review
The previous patch failed on tinderbox because it was affected by other tests setting cookie.
Attachment #697387 - Attachment is obsolete: true
Attachment #697387 - Flags: review?(bzbarsky)
Attachment #697407 - Flags: review?(bzbarsky)
Comment on attachment 697407 [details] [diff] [review]
patch v2

r=me
Attachment #697407 - Flags: review?(bzbarsky) → review+
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/5029e7c89abd
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.