Last Comment Bug 826166 - Remove an ability to set higher JS versions via language attribute
: Remove an ability to set higher JS versions via language attribute
Status: RESOLVED FIXED
: addon-compat, dev-doc-needed
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla21
Assigned To: Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-02 23:44 PST by Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953)
Modified: 2013-02-24 02:06 PST (History)
6 users (show)
VYV03354: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
patch (2.17 KB, patch)
2013-01-03 07:22 PST, Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953)
no flags Details | Diff | Splinter Review
patch v2 (5.49 KB, patch)
2013-01-03 08:40 PST, Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953)
jonas: review+
Details | Diff | Splinter Review

Description Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953) 2013-01-02 23:44:47 PST
The language attribute is obsolete in HTML5 and "JavaScript" is the only speced value. It is ignored when the type attribute is present.
http://www.whatwg.org/specs/web-apps/current-work/multipage/obsolete.html#obsolete-but-conforming-features
IE and Opera doesn't support language="JavaScript1.6" to  language="JavaScript1.8". Chrome recognize the language="JavaScript1.6" and language="JavaScript1.7", but no language extensions are enabled.
XUL doesn't support the language attribute, so it should have no add-on impact.
No in-tree consumers use the language attribute to enable language extensions.
Comment 1 Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953) 2013-01-03 07:22:36 PST
Created attachment 697450 [details] [diff] [review]
patch
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2013-01-03 07:45:36 PST
Get rid of the outparam, please.
Comment 3 Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953) 2013-01-03 08:40:13 PST
Created attachment 697481 [details] [diff] [review]
patch v2

Removed the useless outparam.
According to the comment, the language attribute already lost the ability in HTML.

> XUL doesn't support the language attribute
And it looks like it was wrong.
Comment 4 Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953) 2013-02-04 13:42:06 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/fcb1d5ec2d60
Comment 5 Ryan VanderMeulen [:RyanVM] 2013-02-05 07:37:59 PST
https://hg.mozilla.org/mozilla-central/rev/fcb1d5ec2d60
Comment 6 Kohei Yoshino [:kohei] 2013-02-23 23:32:04 PST
I've added this bug to the compatibility doc. Please correct the info if I'm wrong.
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_21
Comment 7 Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953) 2013-02-24 01:56:03 PST
(In reply to Kohei Yoshino from comment #6)
> I've added this bug to the compatibility doc. Please correct the info if I'm
> wrong.
> https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_21

The language attribute in HTML used to ignore the JS version before this bug. This bug is just a cleanup for Web pages.
On the other hand, XUL language attribute has changed the behavior. Therefore, this is a add-on compatibility bug (not site compatibility).
Comment 8 Kohei Yoshino [:kohei] 2013-02-24 02:06:55 PST
Oh, Okay. Removed this bug from the document.

Note You need to log in before you can comment on or make changes to this bug.