xmlrpc interface on bugzilla.allizom.org returns 302 *and* the payload

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
6 years ago
4 months ago

People

(Reporter: glob, Assigned: gerv)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
spun off from bug 816652:

attachment 697374 [details] - Script to reproduce problem

The attached script, when run against allizom, results in a "302 Found" response which nonetheless has a content body with the history in it. This is weird. The BZ::Client library can't cope with that. When run against bmo, it also returns the correct data, but with a "200" response.

Therefore, there is some configuration difference between allizom and bmo here.

It could be that BZ::Client should do better here, but it seems best to first investigate why these two environments are different. If we can fix that, we can solve the problem quicker.
Could this be some intermediate "transparent" proxy thing?

Gerv
(Reporter)

Comment 2

6 years ago
and a few seconds after creating this bug, i found the cause of the issue:

you're posting to: https://bugzilla.allizom.org/xmlrpc.cgi/xmlrpc.cgi
note the double /xmlrpc.cgi

using the correct url results in a 200 response.


i'm not sure if this is worth investigating further, as i'm surprised it works correctly on the current system.  thoughts?
(Reporter)

Comment 3

6 years ago
(In reply to Gervase Markham [:gerv] from comment #1)
> Could this be some intermediate "transparent" proxy thing?

no, there's no proxy (yet!)
(In reply to Byron Jones ‹:glob› from comment #2)
> you're posting to: https://bugzilla.allizom.org/xmlrpc.cgi/xmlrpc.cgi
> note the double /xmlrpc.cgi

Carefully checking that the test script does the same thing as the production code: Check
Carefully checking that this thing is actually sane: Oops, missed that step

:-)

I have a one-line fix for this. I'm amazed it's worked for so long.

Gerv
Assignee: nobody → gerv
Component: General → BzAPI
Product: bugzilla.mozilla.org → Webtools
Version: Development/Staging → 1.1
gerv@mink:/usr/src/bzapi$ hg ci
lib/Bugzilla/API/Request.pm
committed changeset 187:79f7901bee7f
gerv@mink:/usr/src/bzapi$ hg push
pushing to ssh://hg.mozilla.org/webtools/bzapi

Gerv
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

4 months ago
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.