If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

video unmutes itself after seeking

VERIFIED FIXED in Firefox 20

Status

()

Core
Audio/Video
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: vlad, Assigned: padenot)

Tracking

({regression})

20 Branch
mozilla21
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox17 unaffected, firefox18 unaffected, firefox19 unaffected, firefox20+ verified, firefox21 verified)

Details

Attachments

(1 attachment)

Nightly from a few days ago.

STR:

- Open a video, e.g. http://media.grabaperch.com/video/perch2/perch2home.ogv (doesn't matter if it's embedded or direct)

- Start it playing, click the speaker icon to mute

- Click on the time bar to seek to another time

- Video becomes unmuted, though the speaker icon still shows 0.  You have to click it twice to get it to mute again.

- Seek again, it becomes unmuted.

Expected results:

Video should stay muted after seeking.
This is WFM against 

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0 ID:20121128204232
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 ID:20121231071231
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20130104 Firefox/19.0 ID:20130104042023
status-firefox17: --- → unaffected
status-firefox18: --- → unaffected
status-firefox19: --- → unaffected
status-firefox20: --- → affected
tracking-firefox20: --- → ?
Keywords: regressionwindow-wanted
Version: unspecified → 20 Branch

Updated

5 years ago
Keywords: qawanted

Comment 2

5 years ago
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/dd00a3bad021
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0 ID:20121122020052
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a20b32f37e7a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0 ID:20121122023852
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=dd00a3bad021&tochange=a20b32f37e7a

Regressed by:
265233a61624	Paul Adenot — Bug 495040 - Implement playbackRate and related bits r=kinetik
Blocks: 495040
Keywords: qawanted, regressionwindow-wanted → regression
(Assignee)

Updated

5 years ago
Assignee: nobody → paul
(Assignee)

Comment 3

5 years ago
Created attachment 698608 [details] [diff] [review]
Make video keep its muted state after seeking. r=

Oops.
Attachment #698608 - Flags: review?(kinetik)

Updated

5 years ago
tracking-firefox20: ? → +
Attachment #698608 - Flags: review?(kinetik) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4c1215cefbab

Comment 5

5 years ago
Push backed out for Windows pgo-only mochitest-1 timeouts in media tests, since the backout of just 1abf4c88f8f1 didn't work (see bug 793274 comment 12 for example logs):
https://hg.mozilla.org/integration/mozilla-inbound/rev/f2912b7e727a
(Assignee)

Comment 6

5 years ago
After bisecting the queue on try, this patch has been proved to cause no problem [0], note the patch at the top of the queue that requests a PGO build. The problem remains in the other part of the queue [1].

This has been pushed as https://hg.mozilla.org/integration/mozilla-inbound/rev/4e7e543d21b1

[0]: https://tbpl.mozilla.org/?tree=Try&rev=516ddf4c963c
[1]: https://tbpl.mozilla.org/?tree=Try&rev=418c581b8023
(Assignee)

Updated

5 years ago
Duplicate of this bug: 829438
https://hg.mozilla.org/mozilla-central/rev/4e7e543d21b1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
This needs uplift to Aurora branch.
status-firefox21: --- → fixed
Keywords: checkin-needed
Duplicate of this bug: 833106
(Assignee)

Comment 11

5 years ago
Comment on attachment 698608 [details] [diff] [review]
Make video keep its muted state after seeking. r=

[Approval Request Comment]
Bug caused by (feature/regressing bug #): byg 495040
User impact if declined: muted video gets unmuted after seeking.
Testing completed (on m-c, etc.): on m-c, and the code was obviously wrong and the fix straightforward
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #698608 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #698608 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/53687feab57b
status-firefox20: affected → fixed
Keywords: checkin-needed
Verified the issue in 2013-01-03 Nightly following the STR from comment 0. 
Video becomes unmuted after seeking.

Verified the fix for Firefox 20.0 beta 1 (20130220104816).
Video remains on mute while seeking.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
status-firefox20: fixed → verified
Verified as fiex on FF 21 beta 4, using the STR from description.
Build ID: 20130423212553
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0
Status: RESOLVED → VERIFIED
status-firefox21: fixed → verified
You need to log in before you can comment on or make changes to this bug.