Closed Bug 826425 Opened 9 years ago Closed 9 years ago

double-click on finished downloads in Library view doesn't open them

Categories

(Firefox :: Downloads Panel, defect, P1)

x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 20

People

(Reporter: mak, Assigned: mano)

References

Details

(Whiteboard: [testday-20130222])

Attachments

(1 file, 1 obsolete file)

I downloaded 10 files, opened the Library view and double click them to open, nothing happens, no interesting errors reported to the console.
Priority: -- → P1
Summary: double click on completed session downloads in Library view doesn't work → double-click on finished downloads in Library view doesn't open them
Attached patch patch (obsolete) — Splinter Review
Attachment #698011 - Flags: review?(mak77)
Comment on attachment 698011 [details] [diff] [review]
patch

Review of attachment 698011 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/downloads/content/allDownloadsViewOverlay.js
@@ +1119,5 @@
>        }
>      }
> +  },
> +
> +  onDoubleClick: function DPV_onDoubleClick() {

please, handle only left mouse button
Attachment #698011 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/8f9693d92791
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Is it expected that 'old' downloads in the Library will NOT open with double-click as fixed by this patch?

New downloads seems to open OK, older ones do not.

Tested using latest hourly m-c build cset:
https://hg.mozilla.org/mozilla-central/rev/20d1a5916ef6
Win7 X64bit
The 'double-click' to open seems to be intermittant.  I just downloaded another build file from a day or so ago (regression testing) and double-clicking did NOT open as expected and as I stated above about only working with 'New Downloaded Files'.

I also see these errors in Error Console2:

this appears on first open of the Show all Downloads:
Error: TypeError: view.selectNode is not a function
Source file: chrome://browser/content/places/places.js
Line: 64


This error appears when double-clicking a file:
Error: TypeError: this.dataItem is undefined
Source file: resource://gre/modules/DownloadsCommon.jsm
Line: 431


I will be out most of day, so can't file a new bug if needed.  Not sure if this one should be re-opened.
Depends on: 842553
I confirm the fix is verified on FF19b1 and Latest Nightly (2013-02-21) on Windows 7, I could reproduce the issue on Nightly(2013-01-03) but on FF 20.b1 and Latest Nightly it works as expected.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0(20130220104816)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130109 Firefox/21.0(20130109030942)
Status: RESOLVED → VERIFIED
Whiteboard: [testday-20130222]
(In reply to MarioMi (:MarioMi) from comment #7)

Verified Fixed on FF 20.b1 not FF19.b1. My bad!
You need to log in before you can comment on or make changes to this bug.