Last Comment Bug 826563 - CSS validation errors in toolbox.css
: CSS validation errors in toolbox.css
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Framework (show other bugs)
: 20 Branch
: All All
: -- trivial (vote)
: Firefox 20
Assigned To: Sergiu Dumitriu
:
Mentors:
Depends on:
Blocks: 816946 818033
  Show dependency treegraph
 
Reported: 2013-01-03 17:52 PST by Sergiu Dumitriu
Modified: 2013-03-21 07:34 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
Proposed patch (7.62 KB, patch)
2013-01-03 18:07 PST, Sergiu Dumitriu
paul: review+
Details | Diff | Splinter Review
reformated (11.55 KB, patch)
2013-01-04 06:01 PST, Paul Rouget [:paul]
paul: review+
Details | Diff | Splinter Review

Description Sergiu Dumitriu 2013-01-03 17:52:36 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20130101 Firefox/20.0
Build ID: 20130103013203

Steps to reproduce:

Using Nightly (v20) on Linux or Windows, open the Error console, then toggle the developer tools.


Actual results:

In the Error console there's a warning:

    Warning: Expected ':' but found 'size'.  Declaration dropped.
    Source File: chrome://browser/skin/devtools/toolbox.css
    Line: 176

This is caused by the commit for bug 818033, at https://hg.mozilla.org/mozilla-central/diff/4cd6a880978c/browser/themes/gnomestripe/devtools/toolbox.css#l1.163 and https://hg.mozilla.org/mozilla-central/diff/4cd6a880978c/browser/themes/winstripe/devtools/toolbox.css#l1.164

Apart from that, there are other issue that are not reported by Firefox, but which are considered errors by the W3C CSS validation: url() values without quotes around the URL, and a non-standard syntax for radial gradients.
Comment 1 Sergiu Dumitriu 2013-01-03 18:07:25 PST
Created attachment 697751 [details] [diff] [review]
Proposed patch
Comment 2 Alice0775 White 2013-01-03 20:12:39 PST
Confirmed 
http://hg.mozilla.org/mozilla-central/rev/6955309291ee
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130103 Firefox/20.0 ID:20130103030946

Warning: Expected ':' but found 'size'.  Declaration dropped.
Source file: chrome://browser/skin/devtools/toolbox.css
Line: 177
Comment 3 Mihai Sucan [:msucan] 2013-01-04 02:47:23 PST
Thank you for your patch Sergiu!

When the patch is ready for review, please ask someone for a review.

Details at:
https://developer.mozilla.org/en-US/docs/Developer_Guide/How_to_Submit_a_Patch
Comment 4 Paul Rouget [:paul] 2013-01-04 05:58:36 PST
Comment on attachment 697751 [details] [diff] [review]
Proposed patch

Thank you!
Comment 5 Paul Rouget [:paul] 2013-01-04 06:01:52 PST
Created attachment 697888 [details] [diff] [review]
reformated

Patch from Sergiu, with author name + bug summary + 8 lines of context.

Sergiu, thank you for fixing this. For your next patches, please look at this: https://developer.mozilla.org/en-US/docs/Creating_a_patch
Comment 6 Sergiu Dumitriu 2013-01-04 07:35:56 PST
Thanks for the tips, Paul.
Comment 7 Panos Astithas [:past] 2013-01-04 13:07:33 PST
https://hg.mozilla.org/integration/fx-team/rev/34eac9bec3af
Comment 8 Panos Astithas [:past] 2013-01-05 01:50:13 PST
https://hg.mozilla.org/mozilla-central/rev/34eac9bec3af
Comment 9 Mihai Morar, (:MihaiMorar) 2013-03-21 07:34:56 PDT
I confirm the fix is verified on FF 20b6 on Windows 7 x64 and Ubuntu 12.04:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0(20130320062118)
Mozilla/5.0 (X11; Linux i68; rv:20.0) Gecko/20100101 Firefox/20.0(20130320062118)

Note You need to log in before you can comment on or make changes to this bug.