Closed Bug 826565 Opened 7 years ago Closed 7 years ago

Updates on elm are currently failing

Categories

(Firefox for Metro Graveyard :: General, defect)

x86_64
Windows 8
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 793767

People

(Reporter: jimm, Assigned: glandium)

References

Details

(Whiteboard: [completed-elm])

Attachments

(1 file)

Tried doing an update from the about option but wasn't able to. This was with metrofx running and shutdown.

bbondy, any suggestions on logs and such to look at to diagnose?
Probably related to recent packager changes done which reverted some of the previous updater work on elm.  I'll take a look thanks for bringing it up.  I'll let you know if I need logs.
Assignee: nobody → netzen
This changeset hosed updates on elm. 
Unfortunately there is no tracking bug associated with the commit.
https://hg.mozilla.org/projects/elm/rev/d340f9e6ade9

Basically it thinks the installation directory is <installdir>\browser and so it can't find update-settings.ini and therefore the channel check on the MAR file fails. 

CC'ing glandium for recommended fix since I previously already fixed this once before it was reverted.
Users who updated to any recent builds on elm will need to reinstall to get updates by the way.
Assignee: netzen → mh+mozilla
(In reply to Brian R. Bondy [:bbondy] from comment #2)
> This changeset hosed updates on elm. 
> Unfortunately there is no tracking bug associated with the commit.
> https://hg.mozilla.org/projects/elm/rev/d340f9e6ade9

That changeset is an intermediate step. https://hg.mozilla.org/projects/elm/rev/336034681e01 introduces a replacement.
The value of installDir at this location (passed via toolkit/xre via command line parameters) is <installationdir>/browser

http://dxr.mozilla.org/mozilla-central/toolkit/mozapps/update/updater/updater.cpp.html?string=UpdateThreadFunc#l2086

Can you take a look?
Attached patch Tentative patchSplinter Review
Can you try this?

(This would need to be merged with bug 793767)
Comment on attachment 697971 [details] [diff] [review]
Tentative patch

Review of attachment 697971 [details] [diff] [review]:
-----------------------------------------------------------------

Pretty sure this is correct but having trouble testing it at the moment. Let's just push to elm since it can't do any harm to the current update situation. I'll verify there and let you know if there is a problem.

::: toolkit/xre/nsUpdateDriver.cpp
@@ +994,5 @@
>        updRoot = dirProvider->GetAppDir();
>  
>      greDir = dirProvider->GetGREDir();
> +    nsCOMPtr<nsIFile> exeFile;
> +    rv = mDirProvider.GetFile(XRE_EXECUTABLE_FILE, &persistent,

- mDirProvider.  ...
+ dirProvider->  ...
Attachment #697971 - Flags: review+
backed out due to build bustage on osx.

https://hg.mozilla.org/projects/elm/rev/7c83383dc808
Whiteboard: [completed-elm]
(In reply to Brian R. Bondy [:bbondy] from comment #10)
> Comment 7 :)

Well that's easy to fix. :) Do you think that's the only issue?
Blocks: metro-build
Yes the patch wouldn't compile on windows either because of that, after that fix it compiled fine. I didn't get to test an update but it's easier to test on elm.
Depends on: 829415
Summary of the remaining problem can be found here: 829415

Basically there were 2 problems, and glandium's fix did fix the first.
The second problem is related to how things are being signed at build time. I think it got messed up when we added in the other platforms.  Both MARs and exes are being signed wrong, which are signed in independent ways.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 793767
You need to log in before you can comment on or make changes to this bug.