If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to type in TEXTAREA fields in Nightly

RESOLVED DUPLICATE of bug 825498

Status

()

Firefox for Android
Keyboards and IME
--
critical
RESOLVED DUPLICATE of bug 825498
5 years ago
a year ago

People

(Reporter: justdave, Assigned: jchen)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

20.0a1 (2013-01-03)

Using a bluetooth keyboard or any of the software keyboards on my Samsung Galaxy Tab 10.1 with CM9 (Android 4.0.4)

I can type in the URL bar and in type=input fields, but I am unable to type in TEXTAREA fields (such as the comment box on Bugzilla).

I can *not* reproduce this on my HTC Evo 3D with Android 4.0.3 on it (it works fine on that device).

There is also no useful console output via adb logcat while attempting to type.

Updated

5 years ago
Assignee: nobody → nchen
Can you test this nightly try build? http://ftp-scl3.mozilla.com/pub/mozilla.org/firefox/try-builds/nchen@mozilla.com-569ef28b7d29/try-android/fennec-20.0a1.en-US.android-arm.apk

It has additional logging enabled, so maybe you can give me an adb logcat for textarea and one for type=input for comparison.
Flags: needinfo?(justdave)
Created attachment 698145 [details]
adb logcat -v threadtime | grep Gecko

ok, maybe I was presumptuous that type=input worked, because it doesn't either. Or maybe that changed with this build.  I *can* still type in the URL bar though.

And upon additional testing and watching the log, it's clear that it's ignoring the bluetooth keyboard.  The soft keyboards appear to work, as long as you don't type on the bluetooth keyboard first.  Typing on the bluetooth keyboard stops all input from any source until you tap outside the textarea and back in.  Typing on a soft keyboard gives me output with each key as I type, if I haven't typed on the bluetooth first.

Log attached, with comments prefixed with ==== interspersed to show where I did things in the UI.
Flags: needinfo?(justdave)
Thank you for the detailed log! It was very helpful.

I think this bug has the same symptoms as Bug 825498, so I'm marking it as a dupe for now and see if Bug 825498 fixes this as well.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 825498
You need to log in before you can comment on or make changes to this bug.