Closed Bug 826628 Opened 8 years ago Closed 8 years ago

ShadowImageLayerOGL releases its gralloc buffer even though its not done with it

Categories

(Firefox OS Graveyard :: General, defect, P1)

All
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

RESOLVED FIXED
B2G C4 (2jan on)
blocking-basecamp +
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: kanru, Assigned: kanru)

References

Details

Attachments

(1 file)

We need to explicitly call glDeleteTextures to release the underlying image buffer so that the writing side will not get a genlock error.
Assignee: nobody → kchen
Status: NEW → ASSIGNED
Attachment #697839 - Flags: review+
Is this ready for check-in?
blocking-basecamp: --- → +
Priority: -- → P1
Target Milestone: --- → B2G C4 (2jan on)
Duplicate of this bug: 819737
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/dc3d10cccb86

I need to resolve a conflict on aurora and b2g18.
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.